Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 11939 | Accepted: 7493 |
Description
This is an example of one of her creations:
D
/ \
/ \
B E
/ \ \
/ \ \
A C G
/
/
F
To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG.
She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it).
Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree.
However, doing the reconstruction by hand, soon turned out to be tedious.
So now she asks you to write a program that does the job for her!
Input
Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.)
Input is terminated by end of file.
Output
Sample Input
DBACEGF ABCDEFG
BCAD CBAD
Sample Output
ACBFGED
CDAB
Source
#include <stdio.h>
char in[],pre[],*pr;
void maketree(char *in)
{
char *mid,tmp;
if(*in=='\0')
return;
//mid = strchr(in,*pr++);
for(mid=in;*mid!=*pr;)
mid++;
pr++; tmp = *mid;
*mid = '\0';
mid++;
maketree(in);
maketree(mid);
putchar(tmp);
}
int main()
{
while(scanf("%s%s", pre, in) == ) {
pr=pre;
maketree(in);
putchar('\n');
}
return ;
}
我的递归里面因为不是用下标处理的,也没在参数里加长度来判断,所以显得麻烦点。如果加了长度判断,则几行就搞定了(代码来自SCNU变态的小liming):
void solve(char*a,char*b,int L){
char*i;
if(L){
i=strchr(b,*a);
solve(a+,b,i-b);
solve(a-b+i+,i+,b+L-i-);
putchar(*a);
}
}