hdu 4925 Apple Tree

Apple Tree

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 251    Accepted Submission(s): 176


Problem Description
I’ve bought an orchard and decide to plant some apple trees on it. The orchard seems like an N * M two-dimensional map. In each grid, I can either plant an apple tree to get one apple or fertilize the soil to speed up its neighbors’ production. When a grid is fertilized, the grid itself doesn’t produce apples but the number of apples of its four neighbor trees will double (if it exists). For example, an apple tree locates on (x, y), and (x - 1, y), (x, y - 1) are fertilized while (x + 1, y), (x, y + 1) are not, then I can get four apples from (x, y). Now, I am wondering how many apples I can get at most in the whole orchard?
 

Input
The input contains multiple test cases. The number of test cases T (T<=100) occurs in the first line of input.
For each test case, two integers N, M (1<=N, M<=100) are given in a line, which denote the size of the map.
 

Output
For each test case, you should output the maximum number of apples I can obtain.
 

Sample Input
2 2 2 3 3
 

Sample Output
8 32
 

Author
BUPT
 

Source
 



题解及代码:


/*
签到题,按照黑白期盼的形式构造,能够获得最大值。
*/
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;
typedef __int64 ll;
int m,n;
bool judge(int i,int j)
{
    if(i>=1&&i<=m&&j>=1&&j<=n)
        return true;
    return false;
}

int main()
{
    int T;
    cin>>T;
    int i,j;
    int ma[102][102];
    while(T--)
    {
        cin>>m>>n;
        memset(ma,0,sizeof(ma));

        for(i=1;i<=m;i++)
        {
            if(i%2==0) j=1;
            else j=2;
            for(;j<=n;j+=2)
            {
                ma[i][j]=-1;
            }
        }

        ll ans=0;

        for(int i=1;i<=m;i++)
        {
            for(int j=1;j<=n;j++)
            {
                if(ma[i][j]==0)
                {
                    ma[i][j]=1;
                    if(judge(i-1,j)&&ma[i-1][j]==-1)
                    {
                        ma[i][j]*=2;
                    }
                    if(judge(i+1,j)&&ma[i+1][j]==-1)
                    {
                        ma[i][j]*=2;
                    }
                    if(judge(i,j-1)&&ma[i][j-1]==-1)
                    {
                        ma[i][j]*=2;
                    }
                    if(judge(i,j+1)&&ma[i][j+1]==-1)
                    {
                        ma[i][j]*=2;
                    }
                }
            }
        }
       for(int i=1;i<=m;i++)
       {
           for(int j=1;j<=n;j++)
           if(ma[i][j]>0)
           ans+=ma[i][j];
       }
       cout<<ans<<endl;
    }
    return 0;
}


hdu 4925 Apple Tree,布布扣,bubuko.com

hdu 4925 Apple Tree

上一篇:实例详解:反编译Android APK,修改字节码后再回编译成APK


下一篇:C++11线程指南(四)--右值引用与移动语义