题目描述
编写一程序,识别依次读入的一个以“#”为结束符的字符序列是否为形如“序列1@序列2”模式的字符序列。期中序列1和序列2中都不含字符“@”,且序列2是序列1的逆序列。例如“a+b@b+a”是满足条件的序列字符,而“1+3@3-1”则不是。
输入
一个以“#”结束的字符序列。
输出
是满足条件的字符序列输出“yes!”;否则输出“no!”。
样例输入
a+b@b+a#
样例输出
yes!
参考程序
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#define Maxsize 100
typedef char Elemtype;
typedef struct
{
/* 定义栈 */
Elemtype data[Maxsize];
int top;
}SqStack;
void InitStcak(SqStack *&s)
{
/* 初始化栈操作 */
s = (SqStack *) malloc (sizeof(SqStack)); //分配一个顺序栈空间,首地址存放在s中;
s->top=-1; //栈顶指针置为-1;
}
bool StackEmpty(SqStack *s)
{
/* 判断栈是否为空 */
return(s->top == -1); //判断s->top == -1 是否成立;
}
bool Push(SqStack *&s, Elemtype e)
{
/* 进栈操作 */
if(s->top == Maxsize-1) //判断栈是否满;
return false;
s->top++;
s->data[s->top] = e; //赋值;
return true;
}
bool Pop(SqStack *&s)
{
/* 出栈操作 */
if(s->top == -1)
return false;
// e = s->data[s->top]; //将此时栈顶元素赋值给e,并返回e的值;
s->top--;
return true;
}
int main()
{
SqStack *s;
InitStcak(s);
int n;
char c[100];
scanf("%s", c);
n = strlen(c);
int i;
for(i=0; c[i] != '@'; i++)
Push(s, c[i]);
i++;
for(; i<n; i++)
{
if(s->data[s->top] == c[i])
Pop(s);
else break;
}
if(StackEmpty(s)) printf("yes!");
else printf("no!");
return 0;
}
注意
该程序仅供学习参考!