【poj2155】Matrix(二维树状数组区间更新+单点查询)

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N).

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2). 
2. Q x y (1 <= x, y <= n) querys A[x, y]. 

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case. 
The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above. 

Output

For each querying output one line, which has an integer representing A[x, y]. 
There is a blank line between every two continuous test cases. 

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1

【题意】

n*n坐标图起初都为0,C:翻转左下和右上两个坐标围成的矩阵中所有点,Q:查询此点的0 1状态

【思路】

二维树状数组区间修改+单点查询模板题,先考虑一维。

一维单点查询就是前缀和,即query(x)。

区间修改先让s-n都加num,再让t+1-n减去num,即update(s, num),update(t+1, -num)。

二维的单点查询变成二维就好了query(x, y)。

区间修改update(x1, y1, num), update(x2+1, y1, -num), update(x1, y2+1, -num), update(x2+1, y2+1, num)。开始也是黑人问号,在纸上画几笔就看出来了。

这道题问得是0 1状态,那么只要统计翻转次数是偶次还是奇次就行了

【代码】

 #include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
const int N = ;
int c[N][N], n;
int lowbit(int x)
{
return x&(-x);
}
void update(int x, int y, int m)
{
for(int i = x; i <= n; i += lowbit(i))
for(int j = y; j <= n; j += lowbit(j))
c[i][j] += m;
}
int query(int x, int y)
{
int sum = ;
for(int i = x; i > ; i -= lowbit(i))
for(int j = y; j > ; j-= lowbit(j))
sum += c[i][j];
return sum;
}
int main()
{
int t, m;
cin>>t;
while(t--)
{
memset(c, , sizeof c);
scanf("%d%d", &n, &m);
while(m--)
{
char c;
scanf(" %c", &c);
if(c == 'C')
{
int x1, x2, y1, y2;
scanf("%d%d%d%d", &x1, &y1, &x2, &y2);
update(x1, y1, );
update(x1, y2+, -);
update(x2+, y1, -);
update(x2+, y2+, );
}
else
{
int x, y;
scanf("%d%d", &x, &y);
printf("%d\n", query(x, y)&);
}
}
if(t) puts("");
}
return ;
}
上一篇:sqlservice 查询该字段的值是否为数字、不包含a-z字母、获取中文的首字母


下一篇:微信导出群记录V2.0