What Is Your Grade?(水,排序)

What Is Your Grade?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 9935    Accepted Submission(s): 3041

Problem Description
“Point, point, life of student!” This is a ballad(歌谣)well known in colleges, and you must care about your score in this exam too. How many points can you get? Now, I told you the rules which are used in this course. There are 5 problems in this final exam. And I will give you 100 points if you can solve all 5 problems; of course, it is fairly difficulty for many of you. If you can solve 4 problems, you can also get a high score 95 or 90 (you can get the former(前者) only when your rank is in the first half of all students who solve 4 problems). Analogically(以此类推), you can get 85、80、75、70、65、60. But you will not pass this exam if you solve nothing problem, and I will mark your score with 50. Note, only 1 student will get the score 95 when 3 students have solved 4 problems. I wish you all can pass the exam!  Come on!
 
Input
Input contains multiple test cases. Each test case contains an integer N (1<=N<=100, the number of students) in a line first, and then N lines follow. Each line contains P (0<=P<=5 number of problems that have been solved) and T(consumed time). You can assume that all data are different when 0<p. A test case starting with a negative integer terminates the input and this test case should not to be processed.
 
Output
Output the scores of N students in N lines for each case, and there is a blank line after each case.
 
Sample Input
4
5 06:30:17
4 07:31:27
4 08:12:12
4 05:23:13
1
5 06:30:17
-1
 
Sample Output
100
90
90
95

100

题解:虽然水题,但是还是贴一下吧,毕竟刚开始没读清题错了几次,贴下长个记性;刚开始读成相同题目的第一名+5了,最后又读了下,发现是前一半的+5。。。

对了,还有像time,rank了都不能在代码里面命名否则ce;

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
const int INF=0x3f3f3f3f;
#define mem(x,y) memset(x,y,sizeof(x))
#define SI(x) scanf("%d",&x)
#define PI(x) printf("%d",&x)
#define P_ printf(" ")
int ans[1010];
int nu[6];
struct Node{
int cnt;
int num;
int hh,mm,dd;
int sec;
Node init(int x){
cnt=x;
scanf("%d",&num);
nu[num]++;
scanf("%d:%d:%d",&hh,&mm,&dd);
sec=hh*60*60+mm*60+dd;
ans[cnt]=50+10*num;
}
friend bool operator < (Node a,Node b){
if(a.num!=b.num)return a.num<b.num;
else return a.sec<b.sec;
}
}dt[1010];
int main(){
int N;
while(SI(N),N!=-1){
mem(nu,0);
for(int i=0;i<N;i++){
dt[i].init(i);
}
sort(dt,dt+N);
for(int i=1;i<=4;i++){
for(int j=0;j<N;j++){
if(dt[j].num==i){
if(nu[i]==1)ans[dt[j].cnt]+=5;
else for(int k=j;k<j+nu[i]/2;k++){
ans[dt[k].cnt]+=5;
}
break;
}
}
}
for(int i=0;i<N;i++){
printf("%d\n",ans[i]);
}
puts("");
}
return 0;
}

  

上一篇:Redis使用及优化入门


下一篇:Signatures of Mutational Processes in Human Cancer