PAT A1042 Shuffling Machine (20 分)

一、题目

Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid “inside jobs” where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

S1, S2, …, S13,
H1, H2, …, H13,
C1, C2, …, C13,
D1, D2, …, D13,
J1, J2
where “S” stands for “Spade”, “H” for “Heart”, “C” for “Club”, “D” for “Diamond”, and “J” for “Joker”. A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer K (≤20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

Sample Input:

2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

Sample Output:

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5

二、题意

(一)单词

单词 意思
Shuffling 洗牌
a deck of 一叠,一副
playing cards 扑克牌
casino 赌场
simulate 模拟
initial status 初始状态
permutation 排列
integer 整数

(二)题目大意

按照给定洗牌序列洗n次牌

三、解题思路

(一)分析

设置3个数组,start,end,next,分别用来存放初始序列,洗牌结果,以及洗牌规则。

(二)注意

1、注意输出格式,不要多输出空格
2、scanf()目前Visual Studio版本中已经弃用了,用scanf_s()函数代替了.
参考文献scanf函数在vs2019中不安全/错误
3、char型数组

四、代码

#include <cstdio>
const int n = 55;
using namespace std;
int main() {
	int k;
	scanf_s("%d", &k);//scanf函数在vs2019中不安全/错误
	int start[n], end[n], next[n];
	for (int j = 1; j < n; j++) {//j不取55
		scanf_s("%d", &next[j]);//scanf函数在vs2019中不安全/错误
		start[j] =j;
	}
	for (int j = 1; j <= k; j++) {
		for (int i = 1; i < 55; i++) {//i不能取55
			end[next[i]] = start[i];
		}
		for (int i = 1; i < 55; i++)
			start[i] = end[i];每一次洗牌后,需要将end数组赋值给start数组供下一次操作使用
	}
	char c[] = "SHCDJ";
	for (int j = 1; j < 55; j++) {//J不取55
		if (j != 1) printf(" ");
		end[j]--;//注意细节
		printf("%c%d", c[end[j] / 13], end[j ]% 13+1);
	}


}
上一篇:55-65


下一篇:剑指55-平衡二叉树