Time Limit:1000MS
Memory Limit:32768KB
Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
?For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
Sample Output
Case 1:
14 1 4
Case 2:
7 1 6
以下是代码:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
|
# include <iostream>
# include <cstring>
# include <cstdio>
# include <cstdlib>
using namespace std;
int main(){
int n,tn;
int news,s,e,t;
int maxn,sum;
cin>> n;
for ( int i= 1 ;i<=n;i++){
sum = 0 ;
maxn = - 20000 ;
news = s = e = 1 ;
scanf( "%d" ,&tn);
for ( int j= 1 ;j<=tn;j++){
scanf( "%d" ,&t);
sum+= t ;
if (sum > maxn){ //目前的和大于记录和,更新和及起点终点
maxn = sum;
e = j;
s = news;
}
if (sum < 0 ){ //目前的和小于0,则将起点定为下一个数,和为0
sum= 0 ;
news=j+ 1 ;
}
}
printf( "Case %d:\n%d %d %d\n" ,i,maxn,s,e);
if (i!=n)printf( "\n" );
}
} |