Description
The least common multiple (LCM) of a set of positive
integers is the smallest positive integer which is
divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.
divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.
Input
Input will consist of multiple problem instances.
The first line of the input file will contain a single
integer indicating the number of problem instances. Each instance will consist of a single line of the
form m n1 n2 n3... nm where m is the number of integers in the set and n1 ...nm are the integers. All
integers will be positive and lie within the range of a 32-bit integer.
integer indicating the number of problem instances. Each instance will consist of a single line of the
form m n1 n2 n3... nm where m is the number of integers in the set and n1 ...nm are the integers. All
integers will be positive and lie within the range of a 32-bit integer.
Output
For each problem instance, output a single line
containing the corresponding LCM. All results will lie
in the range of a 32-bit integer.
in the range of a 32-bit integer.
Sample Input
Original | Transformed |
2 3 5 7 15 6 4 10296 936 1287 792 1
Sample Output
105 10296
思路:
每两个两个求最小公倍数
参考代码:
#include <stdio.h> int
GCD( int
a, int
b) //最大公约数
{ if (!b)
return
a;
return
GCD(b,a%b);
} int
LCM( int
a, int
b) //最小公倍数
{ return
a/GCD(a,b)*b;
} int
a[10000];
int
main()
{ int
t;
scanf ( "%d" ,&t);
while (t--)
{
int
n;
scanf ( "%d" ,&n);
int
i;
for (i=0;i<n;i++)
scanf ( "%d" ,&a[i]);
int
temp=a[0];
for (i=1;i<n;i++)
temp=LCM(temp,a[i]);
printf ( "%d\n" ,temp);
}
return
0;
} |