POJ2456 Aggressive cows【二分搜索】

Aggressive cows
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 33659 Accepted: 15420

Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,…,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don’t like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

  • Line 1: Two space-separated integers: N and C

  • Lines 2…N+1: Line i+1 contains an integer stall location, xi
    Output

  • Line 1: One integer: the largest minimum distance

Sample Input

5 3
1
2
8
4
9

Sample Output

3

Hint

OUTPUT DETAILS:

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3.

Huge input data,scanf is recommended.

Source

USACO 2005 February Gold

问题链接POJ2456 Aggressive cows
问题简述:有N个隔间和C头牛 , 给出n个隔间的位置 ,把每头牛分到一个隔间 ,问怎么分才能使任意两头牛之间的最小距离尽可能的大,求这个最大的最小距离。
问题分析:最大最小距离问题,用二分搜索来解决。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++语言程序如下:

/* POJ2456 Aggressive cows */

#include <iostream>
#include <algorithm>
#include <cstdio>

using namespace std;

const int N = 100000;
int n, c, x[N];

bool judge(int mid)
{
    int last = x[0], cnt = 1;
    for(int i = 1; i < n; i++)
        if(x[i] - last >= mid) cnt++, last = x[i];
    return cnt >= c;
}

int main()
{
    scanf("%d%d", &n, &c);
    for(int i = 0; i < n; i++) scanf("%d", &x[i]);

    sort(x, x + n);

    int left = 1, right = x[n - 1] / c, mid;
    while(left < right) {
        mid = (left + right + 1) / 2;
        if(judge(mid)) left = mid;
        else right = mid - 1;
    }

    printf("%d\n", left);

    return 0;
}
上一篇:DLC双端锁,CAS,ABA问题


下一篇:在linux上和window上运行deeplabcut,使用GPU(有点乱,还没整理)