The standard form of a telephone number is seven decimal digits with a hyphen between the third and fourth digits (e.g. 888-1200). The keypad of a phone supplies the mapping of letters to numbers, as follows:
A, B, and C map to 2
D, E, and F map to 3
G, H, and I map to 4
J, K, and L map to 5
M, N, and O map to 6
P, R, and S map to 7
T, U, and V map to 8
W, X, and Y map to 9
There is no mapping for Q or Z. Hyphens are not dialed, and can be added and removed as necessary. The standard form of TUT-GLOP is 888-4567, the standard form of 310-GINO is 310-4466, and the standard form of 3-10-10-10 is 310-1010.
Two telephone numbers are equivalent if they have the same standard form. (They dial the same number.)
Your company is compiling a directory of telephone numbers from local businesses. As part of the quality control process you want to check that no two (or more) businesses in the directory have the same telephone number.
Input
The input will consist of one case. The first line of the input specifies the number of telephone numbers in the directory (up to 100,000) as a positive integer alone on the line. The remaining lines list the telephone numbers in the directory, with each number alone on a line. Each telephone number consists of a string composed of decimal digits, uppercase letters (excluding Q and Z) and hyphens. Exactly seven of the characters in the string will be digits or letters.Output
Generate a line of output for each telephone number that appears more than once in any form. The line should give the telephone number in standard form, followed by a space, followed by the number of times the telephone number appears in the directory. Arrange the output lines by telephone number in ascending lexicographical order. If there are no duplicates in the input print the line:No duplicates.
Sample Input
12 4873279 ITS-EASY 888-4567 3-10-10-10 888-GLOP TUT-GLOP 967-11-11 310-GINO F101010 888-1200 -4-8-7-3-2-7-9- 487-3279
Sample Output
310-1010 2 487-3279 4 888-4567 3#define _CRT_SECURE_NO_WARNINGS
题解:
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
int n;
cin >> n;
char(*num)[100] = new char[n][100];
int *newNum = new int[n];
for (int i = 0; i < n; i++) {
cin >> num[i];
} for (int i = 0; i < n; i++) {
newNum[i] = 0;
for (int j = 0; j < strlen(num[i]); j++) {
if (num[i][j] != '-') {
if (num[i][j] >= 48 && num[i][j] <= 57) {
newNum[i] = newNum[i] * 10 + num[i][j] - 48;
}else {
if (num[i][j] == 'A' || num[i][j] == 'B' || num[i][j] == 'C') {
newNum[i] = newNum[i] * 10 + 2;
continue;
}
if (num[i][j] == 'D' || num[i][j] == 'E' || num[i][j] == 'F') {
newNum[i] = newNum[i] * 10 + 3;
continue;
}
if (num[i][j] == 'G' || num[i][j] == 'H' || num[i][j] == 'I') {
newNum[i] = newNum[i] * 10 + 4;
continue;
}
if (num[i][j] == 'J' || num[i][j] == 'K' || num[i][j] == 'L') {
newNum[i] = newNum[i] * 10 + 5;
continue;
}
if (num[i][j] == 'M' || num[i][j] == 'N' || num[i][j] == 'O') {
newNum[i] = newNum[i] * 10 + 6;
continue;
}
if (num[i][j] == 'P' || num[i][j] == 'R' || num[i][j] == 'S') {
newNum[i] = newNum[i] * 10 + 7;
continue;
}
if (num[i][j] == 'T' || num[i][j] == 'U' || num[i][j] == 'V') {
newNum[i] = newNum[i] * 10 + 8;
continue;
}
if (num[i][j] == 'W' || num[i][j] == 'X' || num[i][j] == 'Y') {
newNum[i] = newNum[i] * 10 + 9;
}
}
}
}
}
sort(newNum, newNum + n);
/*for (int i = 0; i < n; i++) {
cout << newNum[i] << endl;
}*/
int ret ;
struct duplicates
{
int num;
int c;
}du;
int no = 0;
for (int i = 0; i < n-1; i++) {
ret = 1;
while (newNum[i] == newNum[i + 1]) {
if (i + 1 == n) {
break;
}
ret++;
i++;
}
if (ret > 1) {
du.num = newNum[i];
du.c = ret;
no = 1;
cout << du.num / 10000 << "-" << du.num % 10000 << " " << du.c << endl;
}
i++;
}
if (no == 0) {
cout << "No duplicates." << endl;
}
return 0;
}