习题8-7 字符串排序 (20 分)-PTA浙大版《C语言程序设计(第4版)》

本题要求编写程序,读入5个字符串,按由小到大的顺序输出。

输入格式:

输入为由空格分隔的5个非空字符串,每个字符串不包括空格、制表符、换行符等空白字符,长度小于80。

输出格式:

按照以下格式输出排序后的结果:

After sorted:
每行一个字符串

输入样例:

red yellow blue black white

结尾无空行

输出样例:

After sorted:
black
blue
red
white
yellow

结尾无空行

#include<string.h>
#include<stdio.h>
#include<stdlib.h>
struct ch {
	char ch[80];
};
int cmp_char(const* e1, const* e2)
{
	return strcmp(((struct ch*)e1)->ch, ((struct ch*)e2)->ch);
}
int main()
{	
	struct ch arr[5];
	int k = 0;
	for (k = 0; k < 5; k++)
	{
		scanf("%s", arr[k].ch);
	}
	qsort(arr, 5, sizeof(arr[0]), cmp_char);
	int i = 0;
	printf("After sorted:\n");
	for (i = 0; i < 5; i++)
	{
		printf("%s", arr[i].ch);
		if (i != 4)
		{
			printf("\n");
		}
	}
	return 0;
}

上一篇:C语言数组操作


下一篇:快速搜索