PTA甲级1016Phone Bills (25分)

1016 Phone Bills (25分)

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (≤1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word on-line or off-line.

For each test case, all dates will be within a single month. Each on-line record is paired with the chronologically next record for the same customer provided it is an off-line record. Any on-line records that are not paired with an off-line record are ignored, as are off-line records not paired with an on-line record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers’ names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:

10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line

Sample Output:

CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

首先真的要吐槽一下,题目真的是太太太太长了。。。。简直了。。。。

好在思路还是比较简单的。算是一个C++STL的练习题,不用STL的话感觉会麻烦死。。。。

具体的方式就是,map<stirng,vector<node>>来存储每一个人的通话记录,按照通话的时间进行排序,那么理想状态下就是on-line,off-line,on-line,off-line这样重复出现。存储上一个记录的状态,on-line记为true,off-line记为false,如果上一个是true,这次是false添加记录,如果上一个是true,这次是true,更新lastindex,判断下一个,如果上一个是false,遇到下一个true之前,一直跳过就好了。

#include <cstdio>
#include <iostream>
#include <vector>
#include <map>
#include <algorithm>
using namespace std;
double cost[24] = { 0 };
int month;
double dayprice = 0;
struct node {
	int day;
	int hour;
	int mins;
	int time;
	bool flag;
	double price;
	void init(int day, int hour, int mins, bool flag) {
		double price = dayprice * (day - 1);
		int time = 1440 * (day - 1);
		for (int i = 0; i < hour; i++) {
			price += cost[i];
		}
		time += hour * 60;
		price += (cost[hour] / 60) * mins;
		time += mins;
		this->price = price;
		this->day = day;
		this->hour = hour;
		this->mins = mins;
		this->time = time;
		this->flag = flag;
	}
};
typedef struct node Node;

map<string, vector<Node>>mp;

bool cmp(Node a, Node b) {
	return a.time < b.time;
}

void input() {
	mp.clear();
	for (int i = 0; i < 24; i++) {
		scanf("%lf", &cost[i]);
		cost[i] *= 0.6;
		dayprice += cost[i];
	}
	int n;
	scanf("%d", &n);
	string name, status;
	int mon, day, h, mins;
	bool flag;
	Node temp;
	for (int i = 0; i < n; i++) {
		cin >> name;
		scanf("%d:%d:%d:%d", &mon, &day, &h, &mins);
		cin >> status;
		if (status[1] == 'n') {
			flag = true;
		}
		else {
			flag = false;
		}
		temp.init(day, h, mins, flag);
		if (mp.find(name) == mp.end()) {
			mp[name] = vector<Node>();
		}
		mp[name].push_back(temp);
	}
	month = mon;
}

void work() {
	for (map<string, vector<Node>>::iterator iter = mp.begin(); iter != mp.end(); iter++) {
		sort(iter->second.begin(), iter->second.end(), cmp);
		bool flag = false;
		int lastindex = 0;
		double sum = 0;
		for (int i = 0; i < iter->second.size(); i++) {
			if (iter->second[i].flag) {
				flag = true;
				lastindex = i;
			}else if (flag && !iter->second[i].flag) {
				double temp = iter->second[i].price - iter->second[lastindex].price;
				int temptime = (iter->second[i].time - iter->second[lastindex].time);
				if (sum < 1e-11) {
					printf("%s %02d\n", iter->first.c_str(), month);
				}
				printf("%02d:%02d:%02d %02d:%02d:%02d %d $%.2lf\n", iter->second[lastindex].day,
					iter->second[lastindex].hour, iter->second[lastindex].mins,
					iter->second[i].day, iter->second[i].hour, iter->second[i].mins, temptime, temp);
				sum += temp;
				lastindex = i;
				flag = false;
			}else if (!flag) {
				lastindex = i;
			}
		}
		if (sum > 1e-11) {
			printf("Total amount: $%.2lf\n", sum);
		}
	}
}

int main() {
	input();
	work();
	return 0;
}
PTA甲级1016Phone Bills (25分)PTA甲级1016Phone Bills (25分) TimeVshow 发布了38 篇原创文章 · 获赞 2 · 访问量 4842 私信 关注
上一篇:1016 Phone Bills


下一篇:DBCO-C2-PEG4-NH-Boc胺基经弱酸脱Boc保护后,可与羧酸偶联,活化酯基形成酰胺键