PAT A1016 Phone Bills (25 分)

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (≤1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (MM:dd:HH:mm), and the word on-line or off-line.

For each test case, all dates will be within a single month. Each on-line record is paired with the chronologically next record for the same customer provided it is an off-line record. Any on-line records that are not paired with an off-line record are ignored, as are off-line records not paired with an on-line record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers' names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:HH:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:

10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line

Sample Output:

CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

实现思路:

这道题就是一个基本的排序然后筛选数据统计账单的基本题,不过有几个坑点,其中题目没有告知的隐藏条件例如同一个人在某一天内的通话只有一通,不存在多通进行累加,这个点题目是没有说明的,所以这个功能可以不实现,然后对数据的数据根据总时间名字id和times排序,这里说一下通话费用的统计这,我觉得网上大多数的代码我都看了,感觉所用的统计方法都复杂了,直接按照总时间times进行一分钟一分钟累加然后取模+除法的运算取出时间的小时位置的数值来累加电话通话费用即可,详细细节都在备注里已经写明。

AC代码:

#include <iostream>
#include <algorithm>
#include <unordered_map>
#include <cstring>
#include <vector>
using namespace std;
struct node {
	string id,status;
	int mm,dd,hh,ss,times;
};
int toll[25],n;
unordered_map<string,double> mp;

bool cmp(node a,node b) {
	if(a.id!=b.id) return a.id<b.id;
	else return a.times<b.times;
}

double countT(int t1,int t2) {
	double cnt=0;
	while(t1<t2) {
		cnt+=toll[t1/60%(24*30)%24];//根据时间找出小时这个位置的数来累加通话费用
		t1++;
	}
	return cnt;
}

int main() {
	for(int i=0; i<24; i++) scanf("%d",&toll[i]);
	cin>>n;
	vector<node> sq,qe;
	int mm,dd,hh,ss;
	string id,status;
	while(n--) {
		cin>>id;
		scanf("%d:%d:%d:%d",&mm,&dd,&hh,&ss);
		cin>>status;
		sq.push_back(node {id,status,mm,dd,hh,ss,mm*30*24*60+dd*24*60+hh*60+ss});
	}
	sort(sq.begin(),sq.end(),cmp);
	for(int i=0; i<sq.size()-1; i++) {
		if(sq[i].id==sq[i+1].id&&sq[i].status=="on-line"&&sq[i+1].status=="off-line") {
			qe.push_back(sq[i]);
			qe.push_back(sq[i+1]);
		}
	}
	for(int i=0; i<qe.size(); i+=2) {
		string id=qe[i].id;
		int t1=qe[i].times,t2=qe[i+1].times;
		if(mp.count(id)==0) printf("%s %02d\n",qe[i].id.c_str(),qe[i].mm);//如果没有输出过该名字的用户输出其名字和账单月份
		double val=countT(t1,t2);//计算当天该用户的通话费
		printf("%02d:%02d:%02d %02d:%02d:%02d %d $%.2f\n",qe[i].dd,qe[i].hh,qe[i].ss,qe[i+1].dd,
		       qe[i+1].hh,qe[i+1].ss,t2-t1,val/100);
		mp[id]+=val;//统计该用户所有的通话费用
//如果当前用户和下一个要输出用户不为同一个或者当前用户是最后一个用户时输出该用户的总通话费用
		if((i+2<qe.size()&&qe[i].id!=qe[i+2].id)||i+2==qe.size()) {
			printf("Total amount: $%.2f\n",mp[id]/100);
		}
	}
	return 0;
}
上一篇:PTA B1016 Phone Bills 模拟题


下一篇:力扣860题(柠檬水找零)