[poj P2976] Dropping tests

[poj P2976] Dropping tests

Time Limit: 1000MS  Memory Limit: 65536K

Description

In a certain course, you take n tests. If you get ai out of bi questions correct on test i, your cumulative average is defined to be

[poj P2976] Dropping tests.

Given your test scores and a positive integer k, determine how high you can make your cumulative average if you are allowed to drop any k of your test scores.

Suppose you take 3 tests with scores of 5/5, 0/1, and 2/6. Without dropping any tests, your cumulative average is [poj P2976] Dropping tests. However, if you drop the third test, your cumulative average becomes [poj P2976] Dropping tests.

Input

The input test file will contain multiple test cases, each containing exactly three lines. The first line contains two integers, 1 ≤ n ≤ 1000 and 0 ≤ k < n. The second line contains n integers indicating ai for all i. The third line contains n positive integers indicating bi for all i. It is guaranteed that 0 ≤ ai ≤ bi ≤ 1, 000, 000, 000. The end-of-file is marked by a test case with n = k = 0 and should not be processed.

Output

For each test case, write a single line with the highest cumulative average possible after dropping k of the given test scores. The average should be rounded to the nearest integer.

Sample Input

3 1
5 0 2
5 1 6
4 2
1 2 7 9
5 6 7 9
0 0

Sample Output

83
100

Hint

To avoid ambiguities due to rounding errors, the judge tests have been constructed so that all answers are at least 0.001 away from a decision boundary (i.e., you can assume that the average is never 83.4997).

Source

01分数规划入门题。

这个不等式会经常看到:sigma(ai)/sigma(bi)>=(或<=)k

对于这题来说就是,找出最大的k,使得100*sigma(ai)/sigma(bi)>=k。

我们尝试化简上式。

因为bi>=0,所以sigma(bi)>=0,100*sigma(ai)>=k*sigma(bi)

100*sigma(ai)-k*sigma(bi)>=0

sigma(100*ai-k*bi)>=0

那么,我们只要先枚举一个k,将100*ai-k*bi作为关键字排序,再选出前n-k大的,判断一下sum是否非负就行了。

然后我们发现,上式满足单调性,枚举可以改为用二分。所以总复杂度是O(nlog分数)。

然后这一题我先开大100倍,然后最后再缩小100倍,但是这也会有精度误差。

总之,开大的倍数越大,误差越小,但效率越低,但也低不到哪里去qwq

code:

 #include<cstdio>
 #include<cstring>
 #include<algorithm>
 #define LL long long
 #define M ((L)+(R)>>1)
 using namespace std;
 ,lim=;
 int n,k,L,R,ans,final; LL sum;
 struct ob {LL a,b,c;}o[N];
 bool cmp(ob x,ob y) {return x.c>y.c;}
 bool jug(LL lv) {
     ; i<=n; i++) o[i].c=o[i].a*lim-lv*o[i].b;
     sort(o+,o++n,cmp);
     sum=;
     ; i<=n-k; i++) sum+=o[i].c;
     ;
 }
 int main() {
     while (scanf("%d%d",&n,&k)!=EOF,n|k) {
         ; i<=n; i++) scanf("%lld",&o[i].a);
         ; i<=n; i++) scanf("%lld",&o[i].b);
         ,R=lim; L<=R; )
             ;
             ;
         final=ans/; ans%=;
         ) final+=;
         printf("%d\n",final);
     }
     ;
 }
上一篇:linux及windows文件共享


下一篇:ZMQ示例:使用 curve 进行加密通信