Codeforces Round #238 (Div. 2) D. Toy Sum(想法题)

 传送门

Description

Little Chris is very keen on his toy blocks. His teacher, however, wants Chris to solve more problems, so he decided to play a trick on Chris.

There are exactly s blocks in Chris's set, each block has a unique number from 1 to s. Chris's teacher picks a subset of blocks X and keeps it to himself. He will give them back only if Chris can pick such a non-empty subset Y from the remaining blocks, that the equality holds:

Codeforces Round #238 (Div. 2) D. Toy Sum(想法题)"Are you kidding me?", asks Chris.

For example, consider a case where s = 8 and Chris's teacher took the blocks with numbers 1, 4 and 5. One way for Chris to choose a set is to pick the blocks with numbers 3 and 6, see figure. Then the required sums would be equal: (1 - 1) + (4 - 1) + (5 - 1) = (8 - 3) + (8 - 6) = 7.

Codeforces Round #238 (Div. 2) D. Toy Sum(想法题)

However, now Chris has exactly s = 106 blocks. Given the set X of blocks his teacher chooses, help Chris to find the required set Y!

Input

The first line of input contains a single integer n (1 ≤ n ≤ 5·105), the number of blocks in the set X. The next line contains n distinct space-separated integers x1, x2, ..., xn (1 ≤ xi ≤ 106), the numbers of the blocks in X.

Note: since the size of the input and output could be very large, don't use slow output techniques in your language. For example, do not use input and output streams (cin, cout) in C++.

Output

In the first line of output print a single integer m (1 ≤ m ≤ 106 - n), the number of blocks in the set Y. In the next line output m distinct space-separated integers y1, y2, ..., ym (1 ≤ yi ≤ 106), such that the required equality holds. The sets X and Y should not intersect, i.e. xi ≠ yj for all ij (1 ≤ i ≤ n; 1 ≤ j ≤ m). It is guaranteed that at least one solution always exists. If there are multiple solutions, output any of them.

Sample Input

31 4 5
11

Sample Output

2999993 1000000
11000000 

思路

题意:

从 1 ~ 1000000 中选择 n 个数:x1,x2,...,xn,对 x1-1,x2-1,...xn-1 求和得s1。然后在 1 ~ 1000000 中除已经选择过的n个数中选择一些数,假设为y1, y2,...ym,设s = 1000000,对s-y1,s-y2,...,s-ym求和,如果这个和与s1相等,则输出y1,y2,...,ym

题解:

换个角度思考,由于集合X中:x1,x2,...,xn 是各不相同的,那么在S - X,设为Y(假定S是全集:1,2,...,n)对每个数xi(i : 1 ~ n)一定有相应的s-i+1与之对应(前提是,如果S-xi不在集合X中);如果有相应的s-xi+1在X中,那么可以找没有选择过的yj,s-yj+1来替换xi, s-xi+1。例如X中有 100, 999901而没有99, 999902,那么可以选择99, 999902来替代。效果是相同的。这样Y中的数量跟n是相同的。

官方题解:

Let's define the symmetric number of k to be s + 1 - k. Since in this case s is an even number, k ≠ s - k.

Note that (k - 1) + (s + 1 - k) = s, i.e., the sum of a number and its symmetric is always s. Let's process the given members x of X. There can be two cases:

  1. If the symmetric of x does not belong to X, we add it to Y. Both give equal values to the respective sums: x - 1 = s - (s + 1 - x).
  2. The symmetric of x belongs to X. Then we pick any y that neither y and symmetric of y belong to X, and add them to Y. Both pairs give equal values to the respective sums, namely s.

How to prove that in the second step we can always find such y? Let the number of symmetric pairs that were processed in the step 1 be a, then there remain Codeforces Round #238 (Div. 2) D. Toy Sum(想法题) other pairs. Among them, for Codeforces Round #238 (Div. 2) D. Toy Sum(想法题) pairs both members belong to X, and for other Codeforces Round #238 (Div. 2) D. Toy Sum(想法题)pairs none of the members belong to X. To be able to pick the same number of pairs for Y, as there are in X, we should have

Codeforces Round #238 (Div. 2) D. Toy Sum(想法题)

which is equivalent to  Codeforces Round #238 (Div. 2) D. Toy Sum(想法题), as given in the statement.

Solution complexity: O(s) / O(n).

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn = 1000000;
int vis[1000005];

int main()
{
	int N;
	while (~scanf("%d",&N))
	{
		memset(vis,0,sizeof(vis));
		int tmp,cnt = 0;
		bool first = true;
		for (int i = 0;i < N;i++)
		{
			scanf("%d",&tmp);
			vis[tmp] = 1;
		}
		printf("%d\n",N);
		for (int i = 1;i <= maxn;i++)
		{
			if (vis[i] && !vis[maxn+1-i])
			{
				first?printf("%d",maxn+1-i):printf(" %d",maxn+1-i);
				first = false;
				cnt++;
			}
		}
		for (int i = 1;i <= maxn && cnt != N;i++)
		{
			if (!vis[i] && !vis[maxn+1-i])
			{
				printf(" %d %d",i,maxn+1-i);
				cnt += 2;
			}
		}
		printf("\n");
	}
	return 0;
}

  

上一篇:ueditor 文本编辑器


下一篇:Python学习笔记014——迭代器 Iterator