计算两点间距离

输入两点坐标(X1,Y1),(X2,Y2),计算并输出两点间的距离。

Input输入数据有多组,每组占一行,由4个实数组成,分别表示x1,y1,x2,y2,数据之间用空格隔开。Output对于每组输入数据,输出一行,结果保留两位小数。Sample Input

0 0 0 1
0 1 1 0

Sample Output

1.00
1.41


#include<iostream>
#include<math.h>
#include<iomanip>
#include<stdio.h>
using namespace std;
class Point{
public:
void func1(double x,double y)
{
m_x=x;
m_y=y;
}
double func2(Point &another)
{
double a;
a=sqrt((m_x-another.m_x)*(m_x-another.m_x)+(m_y-another.m_y)*(m_y-another.m_y));
return a;
}
private:
double m_x,m_y;
};
int main()
{
double x,y;
Point p1,p2;
cin>>x>>y;
p1.func1(x,y);
cin>>x>>y;
p2.func1(x,y);
double z;
z=p1.func2(p2);
cout<<fixed<<setprecision(2)<<z<<endl;
return 0;
}

用类方法练习了一下。

上一篇:CentOS6.4系统启动失败故障排查


下一篇:ADO.NET 快速入门(十):过滤数据