题目
哈利喜欢玩角色扮演的电脑游戏《蜥蜴和地下室》。此时,他正在扮演一个魔术师。在最后一关,他必须和一排的弓箭手战斗。他唯一能消灭他们的办法是一个火球咒语。如果哈利用他的火球咒语攻击第i个弓箭手(他们从左到右标记),这个弓箭手会失去a点生命值。同时,这个咒语使与第i个弓箭手左右相邻的弓箭手(如果存在)分别失去b(1 ≤ b < a ≤ 10)点生命值。
因为两个端点的弓箭手(即标记为1和n的弓箭手)与你相隔较远,所以火球不能直接攻击他们。但是哈利能用他的火球攻击其他任何弓箭手。
每个弓箭手的生命值都已知。当一个弓箭手的生命值小于0时,这个弓箭手会死亡。请求出哈利杀死所有的敌人所需使用的最少的火球数。
如果弓箭手已经死亡,哈利仍旧可以将他的火球扔向这个弓箭手。
输入
第一行包含3个整数 n, a, b (3 ≤ n ≤ 10; 1 ≤ b < a ≤ 10),第二行包含n个整数——h1,h2,...,hn (1 ≤ hi ≤ 15), hi 是第i个弓箭手所拥有的生命力。
输出
以一行输出t——所需要的最少的火球数。
输入样例
3 2 1
2 2 2输出样例
1
思路:首先利用残余伤害将第 1、n 两个人打死,然后进行 dfs,需要注意的是,在 dfs 的过程中要更新最小值,此外,弓箭手的生命等于 0 时仍视为存活,只有小于 0 时才死亡
源程序
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<string>
#include<cstring>
#include<cmath>
#include<ctime>
#include<algorithm>
#include<utility>
#include<stack>
#include<queue>
#include<vector>
#include<set>
#include<map>
#define EPS 1e-9
#define PI acos(-1.0)
#define INF 0x3f3f3f3f
#define LL long long
const int MOD = 1E9+7;
const int N = 100+5;
const int dx[] = {-1,1,0,0};
const int dy[] = {0,0,-1,1};
using namespace std;
int h[N];
int n,a,b;
int cnt=INF;
void dfs(int pos,int ans){
if(pos==n){
if(cnt>ans)
cnt=ans;
return;
}
if(h[pos-1]<0)//第pos-1个人死后向后搜索
dfs(pos+1,ans);
int num1=0;//残余伤害杀死第pos-1个的次数
if(h[pos-1]>=0){
num1=h[pos-1]/b+1;
h[pos-1]-=num1*b;
h[pos]-=num1*a;
h[pos+1]-=num1*b;
dfs(pos+1,ans+num1);
h[pos-1]+=num1*b;
h[pos]+=num1*a;
h[pos+1]+=num1*b;
}
int num2=h[pos]/a+1;//杀死第pos个的次数
if(h[pos]>=0&&num1<num2){//第pos个没有杀死且num1杀死的次数比num2次数多
for(int i=num1+1;i<=num2;i++){//在num1到num2间枚举次数
h[pos-1]-=i*b;
h[pos]-=i*a;
h[pos+1]-=i*b;
dfs(pos+1,ans+i);
h[pos-1]+=i*b;
h[pos]+=i*a;
h[pos+1]+=i*b;
}
}
}
int main() {
scanf("%d%d%d",&n,&a,&b);
for(int i=1;i<=n;i++)
scanf("%d",&h[i]);
int res=0;
int num;//打的次数
num=h[1]/b+1;//残余伤害打死第一个
res+=num;
h[1]-=num*b;//打第2个num次后第1个剩余的血量
h[2]-=num*a;//打第2个num次后第2个剩余的血量
h[3]-=num*b;//打第2个num次后第3个剩余的血量
if(h[n]>=0){//最后一个没有打死
num=h[n]/b+1;//打第n-1个的次数
res+=num;
h[n]-=num*b;//打第n-1个num次后第n个剩余的血量
h[n-1]-=num*a;//打第n-1个num次后第n-1个剩余的血量
h[n-2]-=num*b;//打第n-1个num次后第n-2个剩余的血量
}
dfs(2,0);
if(cnt!=INF)
res+=cnt;
printf("%d\n",res);
return 0;
}