Problem Description
有一个大小是 2 x n 的网格,现在需要用2种规格的骨牌铺满,骨牌规格分别是 2 x 1 和 2 x 2,请计算一共有多少种铺设的方法。
Input
输入的第一行包含一个正整数T(T<=20),表示一共有 T组数据,接着是T行数据,每行包含一个正整数N(N<=30),表示网格的大小是2行N列。
Output
输出一共有多少种铺设的方法,每组数据的输出占一行。
Sample Input
3
2
8
12
Sample Output
3
171
2731
Source
思路
典型的铺骨牌题目,可参考(https://www.cnblogs.com/MartinLwx/p/9769122.html)
递推式:\(f[i] = f[i-1] + 2*f[i-2]\)
初始条件:\(f[1]=1,f[2]=3\)
代码
#include<bits/stdc++.h>
using namespace std;
__int64 f[31];
int main()
{
int t;
f[1] = 1; f[2] = 3;
for(int i=3;i<=30;i++)
f[i] = f[i-1] + 2*f[i-2];
cin >> t;
while(t--)
{
int tmp;
cin >> tmp;
cout << f[tmp] << endl;
}
return 0;
}