1015 Reversible Primes

1015 Reversible Primes

A reversible prime in any number system is a prime whose “reverse” in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<10
​5
​​ ) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:
The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:
For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:
73 10
23 2
23 10
-2
Sample Output:
Yes
Yes
No

#include <bits/stdc++.h>
using namespace std;
bool judge(int x)
{
	if(x<=1) return false;
	int sqr=(int)sqrt(1.0*x);
	for(int i=2;i<=sqr;i++){
		if(x%i==0) return false;
	}
	return true;
}
int main()
{
	int n,d;
	while(scanf("%d",&n)!=EOF){
		if(n<0) break;
		cin>>d;
		if(judge(n)==false){
			cout<<"No\n";
			continue;
		}
		int ans[100],num=0,sum=0,h=1;
		do{
			ans[num++]=n%d;
			n/=d;
		}while(n!=0);
		for(int j=num-1;j>=0;j--){
			sum+=ans[j]*h;
			h*=d;
		}
		if(judge(sum)==true) cout<<"Yes\n";
		else cout<<"No\n";
	}
	return 0;
}

上一篇:上门洗车App 竟然是块大肥肉!


下一篇:信息学奥赛一本通(1015:计算并联电阻的阻值)