hdu2377Bus Pass(构建更复杂的图+spfa)

主题链接:

思路:

题目是给了非常多个车站。然后要你找到一个社区距离这些车站的最大值最小。。所以对每一个车站做一次spfa。那么就得到了到每一个社区的最大值,最后对每一个社区扫描一次,得到那个最小值的社区。。

还有题目要求是要最小的id,所以排一次序。

题目:

Bus Pass

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 667    Accepted Submission(s): 271

Problem Description
You travel a lot by bus and the costs of all the seperate tickets are starting to add up. 



Therefore you want to see if it might be advantageous for you to buy a bus pass. 



The way the bus system works in your country (and also in the Netherlands) is as follows: 



when you buy a bus pass, you have to indicate a center zone and a star value. You are allowed to travel freely in any zone which has a distance to your center zone which is less than your star value. For example, if you have a star value of one, you can only
travel in your center zone. If you have a star value of two, you can also travel in all adjacent zones, et cetera. 



You have a list of all bus trips you frequently make, and would like to determine the minimum star value you need to make all these trips using your buss pass. But this is not always an easy task. For example look at the following figure: 



hdu2377Bus Pass(构建更复杂的图+spfa)




Here you want to be able to travel from A to B and from B to D. The best center zone is 7400, for which you only need a star value of 4. Note that you do not even visit this zone on your trips! 
 
Input
On the first line an integert(1 <=t<= 100): the number of test cases. Then for each test case: 



One line with two integersnz(2 <=nz<= 9 999) andnr(1 <=nr<= 10): the number of zones and the number of bus trips, respectively. 



nz lines starting with two integers idi (1 <= idi <= 9 999) and mzi (1 <= mzi <= 10), a number identifying the i-th zone and the number of zones adjacent to it, followed by mzi integers: the numbers of
the adjacent zones. 



nr lines starting with one integer mri (1 <= mri <= 20), indicating the number of zones the ith bus trip visits, followed by mri integers: the numbers of the zones through which the bus passes in the order in which they are
visited. 



All zones are connected, either directly or via other zones. 


 
Output
For each test case: 



One line with two integers, the minimum star value and the id of a center zone which achieves this minimum star value. If there are multiple possibilities, choose the zone with the lowest number. 


 
Sample Input
1
17 2
7400 6 7401 7402 7403 7404 7405 7406
7401 6 7412 7402 7400 7406 7410 7411
7402 5 7412 7403 7400 7401 7411
7403 6 7413 7414 7404 7400 7402 7412
7404 5 7403 7414 7415 7405 7400
7405 6 7404 7415 7407 7408 7406 7400
7406 7 7400 7405 7407 7408 7409 7410 7401
7407 4 7408 7406 7405 7415
7408 4 7409 7406 7405 7407
7409 3 7410 7406 7408
7410 4 7411 7401 7406 7409
7411 5 7416 7412 7402 7401 7410
7412 6 7416 7411 7401 7402 7403 7413
7413 3 7412 7403 7414
7414 3 7413 7403 7404
7415 3 7404 7405 7407
7416 2 7411 7412
5 7409 7408 7407 7405 7415
6 7415 7404 7414 7413 7412 7416
 
Sample Output
4 7400
 
Source
 
Recommend
lcy   |   We have carefully selected several similar problems for you:  2722 2363 2482 2962 1598 

代码为:

#include<cstdio>
#include<queue>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<vector>
#define INF 0x3f3f3f3f
using namespace std; const int maxn=9999+10;
int dis[maxn],id[maxn],max_dis[maxn];
bool vis[maxn];
vector<int>vec[maxn];
int t,n,bus,cal; bool cmp(int a,int b)
{
return a<b;
} void spfa(int st)
{
queue<int>Q;
while(!Q.empty()) Q.pop();
memset(vis,false,sizeof(vis));
memset(dis,INF,sizeof(dis));
Q.push(st);
dis[st]=0;
vis[st]=true;
while(!Q.empty())
{
int temp=Q.front();
Q.pop();
vis[temp]=false;
for(int i=0;i<vec[temp].size();i++)
{
if(dis[temp]+1<dis[vec[temp][i]])
{
dis[vec[temp][i]]=dis[temp]+1;
if(!vis[vec[temp][i]])
{
vis[vec[temp][i]]=true;
Q.push(vec[temp][i]);
}
}
}
}
} void read_graph()
{
memset(max_dis,0,sizeof(max_dis));
int u;
scanf("%d%d",&n,&bus);
for(int i=1;i<=maxn;i++)
vec[i].clear();
for(int i=1;i<=n;i++)
{
scanf("%d%d",&id[i],&cal);
for(int j=1;j<=cal;j++)
{
scanf("%d",&u);
vec[id[i]].push_back(u);
}
}
while(bus--)
{
scanf("%d",&cal);
while(cal--)
{
int st;
scanf("%d",&st);
spfa(st);
for(int i=1;i<=n;i++)
{
if(dis[id[i]]>max_dis[id[i]])
max_dis[id[i]]=dis[id[i]];
}
}
}
int ans=999999999,ans_id;
sort(id+1,id+1+n,cmp);
for(int i=1;i<=n;i++)
{
if(max_dis[id[i]]<ans)
{
ans=max_dis[id[i]];
ans_id=id[i];
}
}
printf("%d %d\n",ans+1,ans_id);
} int main()
{
scanf("%d",&t);
while(t--)
{
read_graph();
}
return 0;
}

版权声明:本文博客原创文章。博客,未经同意,不得转载。

上一篇:微软IOC容器Unity简单代码示例1


下一篇:四种Java线程池用法解析