POJ 3140 树形dp

Contestants Division
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 7725   Accepted: 2196

Description

In the new ACM-ICPC Regional Contest, a special monitoring and submitting system will be set up, and students will be able to compete at their own universities. However there’s one problem. Due to the high cost of the new judging system, the organizing committee can only afford to set the system up such that there will be only one way to transfer information from one university to another without passing the same university twice. The contestants will be divided into two connected regions, and the difference between the total numbers of students from two regions should be minimized. Can you help the juries to find the minimum difference?

Input

There are multiple test cases in the input file. Each test case starts with two integers N and M, (1 ≤ N ≤ 100000, 1 ≤ M ≤ 1000000), the number of universities and the number of direct communication line set up by the committee, respectively. Universities are numbered from 1 to N. The next line has N integers, the Kth integer is equal to the number of students in university numbered K. The number of students in any university does not exceed 100000000. Each of the following M lines has two integers s, t, and describes a communication line connecting university s and university t. All communication lines of this new system are bidirectional.

N = 0, M = 0 indicates the end of input and should not be processed by your program.

Output

For every test case, output one integer, the minimum absolute difference of students between two regions in the format as indicated in the sample output.

Sample Input

7 6
1 1 1 1 1 1 1
1 2
2 7
3 7
4 6
6 2
5 7
0 0

Sample Output

Case 1: 1

Source

[Submit]   [Go Back]   [Status]   [Discuss]


题意:将一颗树分成两颗子树,使得差值尽可能的小。

很简单,直接dp出以每一个点为根的子树的权值,然后根据总权值求出剩余部分的权值,枚举更新得到最小值。

代码:

/* ***********************************************
Author :xianxingwuguan
Created Time :2014-2-6 16:15:10
File Name :1.cpp
************************************************ */
#pragma comment(linker, "/STACK:102400000,102400000")
#include <stdio.h>
#include <iostream>
#include <algorithm>
#include <sstream>
#include <stdlib.h>
#include <string.h>
#include <limits.h>
#include <string>
#include <time.h>
#include <math.h>
#include <queue>
#include <stack>
#include <set>
#include <map>
using namespace std;
#define INF 1000000000000000LL
#define eps 1e-8
#define pi acos(-1.0)
typedef long long ll;
const ll maxn=100100;
ll head[maxn],tol,weight[maxn],dp[maxn];
struct node{
	ll next,to;
	node(){};
	node(ll _next,ll _to):next(_next),to(_to){}
}edge[5*maxn];
void add(ll u,ll v){
	edge[tol]=node(head[u],v);
	head[u]=tol++;
}
void dfs(ll u,ll fa){
	dp[u]=weight[u];
	for(ll i=head[u];i!=-1;i=edge[i].next){
		ll v=edge[i].to;
		if(v==fa)continue;
		dfs(v,u);
		dp[u]+=dp[v];
	}
}
ll ABS(ll x){
	if(x<=0)x=-x;
	return x;
}
int main(){
	ll i,j,k,m,n,p,T=0;
	while(cin>>n>>m){
		if(n==0&&m==0)break;
		memset(head,-1,sizeof(head));
		ll sum=0,ans=INF;
		for(i=1;i<=n;i++)cin>>weight[i],sum+=weight[i];
		while(m--){
			cin>>j>>k;
			add(j,k);
			add(k,j);
		}
		dfs(1,-1);
		for(i=1;i<=n;i++){
			ll pp=ABS(dp[i]-(sum-dp[i]));
			ans=min(ans,pp);
		}
		cout<<"Case "<<++T<<": "<<ans<<endl;
	}
	return 0;
}


POJ 3140 树形dp

上一篇:疑难杂症--由于系统缓冲区空间不足或队列已满,不能执行套接字上的操作


下一篇:uva 11183(最小树形图)