【ZOJ】1457 &【UVA】524Prime Ring Problem素环问题
原题
Time Limit: 10000 ms
Memory Limit: 32768 KB
Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, …, n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.
Note: the number of first circle should always be 1.
Input
n (0 < n < 20)
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.
You are to write a program that completes above process.
Print a blank line after each case.
Sample Input
6
8
Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4
Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2
翻译
输入正整数 n,把整数 1,2,…,n 组成一个环,使得相邻两个整数之和均为素数。输出时,从整数 1 开始逆时针排列。同一个环恰好输出一次。n≤20,保证一定有解。
多组数据,读入到 EOF 结束。
第 i 组数据输出前加上一行 Case i:
相邻两组数据中间加上一个空行。
输入输出样例
输入
6
8
输出
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4
Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2
思路
若n为奇数,跳过。
因为奇数无解。
若n为偶数,用DFS暴力枚举。
注意格式,末尾无空格,两个数据之间有换行。
代码
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int n,b[25];
bool c[25],z[41]={0,0,1,1,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,0,0,0,0,1,0,1,0,0,0,0,0,1,0,0,0};
void DFS(int dep)
{
int i;
if(dep>n)//到达长度
{
if(z[b[n]+1])
{
printf("1");
for(i=2;i<=n;i++)
printf(" %d",b[i]);
printf("\n");
}
return;
}
for(i=2;i<=n;i++)//扩展
if(c[i]&&z[b[dep-1]+i])
{
c[i]=0;
b[dep]=i;
DFS(dep+1);
c[i]=1;
}
return;
}
int main()
{
int i;
b[1]=1;
for(i=1;cin>>n;i++)
{
memset(c,true,sizeof(c));
c[1]=0;
printf("Case %d:\n",i);
if(!(n&1))//跳过奇数
DFS(2);
printf("\n");
}
return 0;
}