The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.
Input Specification:
Each input file contains one test case. For each case, the first line contains an integer N (in [3,105]), followed by N integer distances D1 D2 ⋯ DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.
Output Specification:
For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.
Sample Input:
5 1 2 4 14 9
3
1 3
2 5
4 1
Sample Output:
3
10
7
解题思路:dst[i]数组表示结点i+1到结点1的距离,dst[n]表示整个环的距离,求任意两点i与j的距离可以表示成
res=min(abs(dst[j-1]-dst[i-1]),abs(dst[n]-abs(dst[j-1]-dst[i-1)) 的形式
满分代码如下:
#include<bits/stdc++.h>
using namespace std;
const int N=100005;
int dst[N];
int main(){
memset(dst,0,sizeof(dst));
int n,m;
scanf("%d",&n);
for(int i=1;i<=n;i++){
scanf("%d",&dst[i]);
dst[i]+=dst[i-1];
}
scanf("%d",&m);
int u,v,res;
for(int i=1;i<=m;i++){
scanf("%d%d",&u,&v);
res=min(abs(dst[v-1]-dst[u-1]),abs(dst[n]-abs(dst[v-1]-dst[u-1])));
printf("%d\n",res);
}
return 0;
}