Codeup100000575问题 E: Shortest Distance (20)

题目描述

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

输入

Each input file contains one test case. For each case, the first line contains an integer N (in [3, 1 0 5 10^5 105]), followed by N integer distances D 1 D_1 D1​ D 2 D_2 D2​ … D N D_N DN​, where D i D_i Di​ is the distance between the i-th and the (i+1)-st exits, and D N D_N DN​ is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<= 1 0 4 10^4 104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 1 0 7 10^7 107.

输出

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

样例输入

5 1 2 4 14 9
3
1 3
2 5
4 1

样例输出

3
10
7

实现代码

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

const int maxn = 1e5 + 10;

/*
    此题对时间复杂度的要求很高,O(2n)的复杂度会造成超时,
    故只能在输入时计算好结点i(i>=1)到1的距离来加快计算
*/

int main() {
    int n;
    int D[maxn];
    int dis[maxn];
    int m;
    int l, r;
    while(scanf("%d", &n) != EOF) {
        int sum = 0;
        dis[1] = 0;
        for(int i = 1; i <= n; i++) {
            scanf("%d", &D[i]);
            sum += D[i];
            dis[i + 1] = sum;
        }
        scanf("%d", &m);
        for(int i = 0; i < m; i++) {
            scanf("%d%d", &l, &r);
            if(l > r) {
                swap(l, r);
            }
            int sum1 = dis[r] - dis[l];
            if(sum1 > sum - sum1) {
                printf("%d\n", sum - sum1);
            } else {
                printf("%d\n", sum1);
            }
        }
    }
    return 0;
}

上一篇:compare between Salesforce® and Microsoft Dynamics™365


下一篇:数据库学习(2.2条件查询)DQL语句