HDU1074 Doing Homework

Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test, 1 day for 1 point. And as you know, doing homework always takes a long time. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=15) which indicate the number of homework. Then N lines follow. Each line contains a string S(the subject‘s name, each string will at most has 100 characters) and two integers D(the deadline of the subject), C(how many days will it take Ignatius to finish this subject‘s homework). 

Note: All the subject names are given in the alphabet increasing order. So you may process the problem much easier.
 

Output
For each test case, you should output the smallest total reduced score, then give out the order of the subjects, one subject in a line. If there are more than one orders, you should output the alphabet smallest one.
 

Sample Input
2 3 Computer 3 3 English 20 1 Math 3 2 3 Computer 3 3 English 6 3 Math 6 3
 

Sample Output
2 Computer Math English 3 Computer English Math

dp问题

#include <iostream>
using namespace std;
#include <string>
#include <stack>

struct Q{
	string s;
	int d;
	int c;
};
struct DPT{
	int time;
	int pos;
	int last;
	int score;
};
DPT *dp;
Q *q;
int main()
{
	freopen("C:\\in.txt","r",stdin);
	int T;
	const int INF=0x7fffffff;
	cin>>T;
	while(T--){
		int N;
		cin>>N;
		q=new Q[N];
		dp=new DPT[1<<N];
		for(int i=0;i<N;i++){
			cin>>q[i].s>>q[i].d>>q[i].c;
		}
		int end=1<<N;
		int recent=0;
		int reduce=0;
		int past=0;
		dp[past].score=0;
		dp[past].pos=0;
		dp[past].last=0;
		dp[past].time=0;
		for(int s=1;s<end;s++){
			dp[s].score=INF;
			for(int i=N-1;i>=0;i--){
				recent=1<<i;
				if(s&recent){
					past=s-recent;
					reduce=dp[past].time+q[i].c-q[i].d;
					if(reduce<0)reduce=0;
					if(reduce+dp[past].score<dp[s].score){
						dp[s].score=reduce+dp[past].score;
						dp[s].pos=i;
						dp[s].last=past;
						dp[s].time=dp[past].time+q[i].c;
					}
				}
			}
		}
		stack<int>path;
		recent=end-1;
		while(recent){
			//cout<<dp[recent].pos;
			path.push(dp[recent].pos);
			recent=dp[recent].last;
		}
		cout<<dp[end-1].score<<endl;
		while(!path.empty()){
			int top=path.top();
			cout<<q[top].s<<endl;
			path.pop();
		}
		delete[] q;
		delete[] dp;
	}
	return 0;
}


HDU1074 Doing Homework

上一篇:http链接的性能测试工具httping


下一篇:Git版本控制:Git查阅、撤销文件修改和撤销文件追踪