与昨天一道类似的多重集组合数问题
每个家族有n个蚂蚁,一共T个家族, 问从S到B能有多少组合可能
题目:
Appoint
description:
Description
Bessie was poking around the ant hill one day
watching the ants march to and fro while gathering food. She realized that many
of the ants were siblings, indistinguishable from one another. She also realized
the sometimes only one ant would go for food, sometimes a few, and sometimes all
of them. This made for a large number of different sets of ants!
Being a bit mathematical, Bessie started wondering. Bessie noted that the hive has T (1 <= T <= 1,000) families of ants which she labeled 1..T (A ants altogether). Each family had some number Ni (1 < = Ni <= 100) of ants.
How many groups of sizes S, S+1, ..., B (1 <= S <= B <= A) can be formed?
While observing one group, the set of three ant families was seen as {1, 1, 2, 2, 3}, though rarely in that order. The possible sets of marching ants were:
3 sets with 1 ant: {1} {2} {3}
5 sets with 2 ants: {1,1} {1,2} {1,3} {2,2} {2,3}
5 sets with 3 ants: {1,1,2} {1,1,3} {1,2,2} {1,2,3} {2,2,3}
3 sets with 4 ants: {1,2,2,3} {1,1,2,2} {1,1,2,3}
1 set with 5 ants: {1,1,2,2,3}
Your job is to count the number of possible sets of ants given the data above.
Being a bit mathematical, Bessie started wondering. Bessie noted that the hive has T (1 <= T <= 1,000) families of ants which she labeled 1..T (A ants altogether). Each family had some number Ni (1 < = Ni <= 100) of ants.
How many groups of sizes S, S+1, ..., B (1 <= S <= B <= A) can be formed?
While observing one group, the set of three ant families was seen as {1, 1, 2, 2, 3}, though rarely in that order. The possible sets of marching ants were:
3 sets with 1 ant: {1} {2} {3}
5 sets with 2 ants: {1,1} {1,2} {1,3} {2,2} {2,3}
5 sets with 3 ants: {1,1,2} {1,1,3} {1,2,2} {1,2,3} {2,2,3}
3 sets with 4 ants: {1,2,2,3} {1,1,2,2} {1,1,2,3}
1 set with 5 ants: {1,1,2,2,3}
Your job is to count the number of possible sets of ants given the data above.
Input
* Line 1: 4 space-separated integers: T, A, S, and
B
* Lines 2..A+1: Each line contains a single integer that is an ant type present in the hive
* Lines 2..A+1: Each line contains a single integer that is an ant type present in the hive
Output
* Line 1: The number of sets of size S..B
(inclusive) that can be created. A set like {1,2} is the same as the set {2,1}
and should not be double-counted. Print only the LAST SIX DIGITS of this number,
with no leading zeroes or spaces.
Sample Input
3 5 2 3 1 2 2 1 3
Sample Output
10
Hint
INPUT DETAILS:
Three types of ants (1..3); 5 ants altogether. How many sets of size 2 or size 3 can be made?
OUTPUT DETAILS:
5 sets of ants with two members; 5 more sets of ants with three members
Three types of ants (1..3); 5 ants altogether. How many sets of size 2 or size 3 can be made?
OUTPUT DETAILS:
5 sets of ants with two members; 5 more sets of ants with three members
代码:
1 #include <iostream> 2 #include <cstring> 3 #include <cstdio> 4 5 using namespace std; 6 #define MOD 1000000 7 8 int T,A,S,B; 9 int num[1000+10]; 10 11 int dp[1000+10][100000+10]; 12 int main() 13 { 14 cin>>T>>A>>S>>B; 15 for(int i=0;i<A;i++) 16 { 17 int t; 18 cin>>t; 19 num[t] ++; 20 } 21 for(int i=0;i<=T;i++) 22 dp[i][0] =1; 23 24 for(int i=0;i<T;i++) 25 { 26 for(int j=1;j<=B;j++) 27 { 28 if( j-num[i+1]-1 >=0) 29 { 30 dp[ i+1 ][j] =(dp[i+1][j-1]+dp[i][j]- dp[i][j-1-num[i+1]] +MOD)%MOD; 31 } 32 else 33 { 34 dp[i+1][j] = (dp[i+1][j-1] +dp[i][j]+MOD)%MOD; 35 } 36 } 37 } 38 int ans =0 ; 39 for(int i = S;i<=B;i++) 40 { 41 //cout<<dp[T][i]<<endl; 42 ans+=dp[T][i]; 43 ans%=MOD; 44 } 45 cout<<(ans+MOD)%MOD<<endl; 46 return 0; 47 }