PAT A1025 成绩排序

题目

1025 PAT Ranking (25分)
Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:
For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

输入输出示例

Sample Input:
2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:
9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

解法

#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
struct Student  
{
	string id;
	int score;
	int locationNum;
	int locationRank;
	int finalRank;
}stu[30010];
bool cmp(Student a, Student b) {
	if (a.score != b.score) return a.score > b.score;
	else return a.id<b.id;
}
int main() {
	int N_location;
	int k;
	int num = 0;//学生总数
	//cin >> location;
	scanf("%d", &N_location);
	for (int locationNumber = 1; locationNumber <= N_location; locationNumber++) {
		scanf("%d", &k);
		for (int j = 0; j <k; j++,num++) {
			//scanf("%s %d", stu[num].id,&stu[num].score);
			cin >> stu[num].id >> stu[num].score;
			stu[num].locationNum = locationNumber;
		}
		//location_Rank存入Student中
		sort(stu + num - k, stu + num, cmp);
		stu[num - k].locationRank = 1;
		for (int j = num - k + 1; j < num; j++) {
			if (stu[j].score == stu[j - 1].score) {
				stu[j].locationRank = stu[j - 1].locationRank;
			}
			else {
				//分数不同排名不同 分数相同排名相同但占用一个排位
				//locationRank为该考生前人数+1 
				stu[j].locationRank = j + 1 -( num - k);
			}
		}
	}//for
	printf("%d\n", num);
	sort(stu, stu + num, cmp);
	stu[0].finalRank = 1;
	for (int j = 1; j < num; j++) {
		if (stu[j].score == stu[j - 1].score) {
			stu[j].finalRank = stu[j - 1].finalRank;
		}
		else {
			stu[j].finalRank = j+1;
		}	
	}
	for (int j = 0; j < num; j++) {
		cout << stu[j].id << " " << stu[j].finalRank << " " << stu[j].locationNum << " " << stu[j].locationRank << endl;
	}
	
	return 0;
}
PAT A1025 成绩排序PAT A1025 成绩排序 糟糕吱 发布了3 篇原创文章 · 获赞 0 · 访问量 15 私信 关注
上一篇:Python中的随机采样和概率分布(一)


下一篇:pandas基础操作