1025 PAT Ranking (25point(s))

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

 

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4
#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;
struct student
{
    string id;
    int score;
    int loc;
    int loc_rank;
    int total_rank;
}stu[30005];
bool cmp(student a, student b)
{
    if(a.score != b.score) return a.score > b.score;
    else return a.id < b.id;
}
int main()
{
    int num = 0;//学生总数
    int numloc;
    cin >> numloc;
    for(int i = 1; i <= numloc; i++)
    {
        int numpart;
        cin >> numpart;
        for(int j = 0; j < numpart; j++)
        {
            cin >> stu[num].id >> stu[num].score;
            stu[num].loc = i;
            num++;
        }
        sort(stu + num - numpart, stu + num, cmp);
        stu[num - numpart].loc_rank = 1;
        for(int j = num - numpart + 1; j < num; j++)
        {
            if(stu[j].score == stu[j - 1].score) stu[j].loc_rank = stu[j - 1].loc_rank;
            else stu[j].loc_rank = j + 1 - (num - numpart);
        }

    }
    cout << num << endl;
    sort(stu, stu + num, cmp);
    stu[0].total_rank = 1;
    cout << stu[0].id << " " << stu[0].total_rank << " " << stu[0].loc << " " << stu[0].loc_rank << endl;
    for(int i = 1; i < num; i++)
    {
        cout << stu[i].id << " ";
        if(stu[i].score == stu[i - 1].score) stu[i].total_rank = stu[i - 1].total_rank;
        else stu[i].total_rank = i + 1;
        cout << stu[i].total_rank;
        cout << " " << stu[i].loc << " " << stu[i].loc_rank << endl;
    }
    return 0;
}

 

 

1025 PAT Ranking (25point(s))1025 PAT Ranking (25point(s)) rockkyy 发布了61 篇原创文章 · 获赞 0 · 访问量 4671 私信 关注
上一篇:1025 反转链表 (25分)


下一篇:问题 1025: 数组插入处理