UVA 10881 - Piotr's Ants(思维题)

Piotr likes playing with ants. He has n of them on a horizontal pole L cm long. Each ant is facing either left or right and walks at a constant speed of 1 cm/s. When two ants bump into each other, they both turn around (instantaneously) and start walking in opposite directions. Piotr knows where each of the ants starts and which direction it is facing and wants to calculate where the ants will end up T seconds from now.

Input
The first line of input gives the number of cases, NN test cases follow. Each one starts with a line containing 3 integers: L , T and n (0 <= n <= 10000). The next n lines give the locations of the n ants (measured in cm from the left end of the pole) and the direction they are facing (L or R).

Output
For each test case, output one line containing "Case #x:" followed by n lines describing the locations and directions of the n ants in the same format and order as in the input. If two or more ants are at the same location, print "Turning" instead of "L" or "R" for their direction. If an ant falls off the pole before T seconds, print "Fell off" for that ant. Print an empty line after each test case.

Sample Input Sample Output
2
10 1 4
1 R
5 R
3 L
10 R
10 2 3
4 R
5 L
8 R
Case #1:
2 Turning
6 R
2 Turning
Fell off

Case #2:
3 L
6 R
10 R


题意:给出一根长度为L厘米的棒子上的n个蚂蚁的位置和方向,速度为每秒1厘米,两蚂蚁相撞后立即同时调头。求出T秒后的状态。


思路:因为速度相等,如果不用分清谁和谁的话,两蚂蚁相撞后调头就等价于二者对穿而过。  并且所有蚂蚁的相对顺序是不变的,这道题就可以做了。


#include <stdio.h>

struct{
int id,d,fx;
}a[10000],temp;

int order[10000];

int main()
{
    int K,kase,L,T,n,i,j;
    char c;

    scanf("%d",&K);

    for(kase=1;kase<=K;kase++)
    {
        scanf("%d%d%d",&L,&T,&n);

        for(i=0;i<n;i++)
        {
            a[i].id=i;
            scanf("%d %c",&a[i].d,&c);
            a[i].fx=(c==‘R‘?1:-1);//1代表向右,-1代表向左
        }

        for(i=0;i<n-1;i++)
        {
            for(j=0;j<n-i-1;j++)
            {
                if(a[j].d<a[j+1].d)
                {
                    temp=a[j];
                    a[j]=a[j+1];
                    a[j+1]=temp;
                }
            }
        }

        for(i=0;i<n;i++) order[a[i].id]=i;//原来第i个就是排序之后的第order[i]个

        for(i=0;i<n;i++) a[i].d+=a[i].fx*T;

        for(i=0;i<n-1;i++)
        {
            for(j=0;j<n-i-1;j++)
            {
                if(a[j].d<a[j+1].d)
                {
                    temp=a[j];
                    a[j]=a[j+1];
                    a[j+1]=temp;
                }
            }
        }

        for(i=0;i<n-1;i++) if(a[i].d==a[i+1].d) a[i].fx=a[i+1].fx=0;//调头中

        printf("Case #%d:\n",kase);

        for(i=0;i<n;i++)
        {
            if(a[order[i]].d<0 || a[order[i]].d>L) printf("Fell off\n");
            else
            {
                printf("%d ",a[order[i]].d);
                if(a[order[i]].fx==1) printf("R\n");
                if(a[order[i]].fx==-1) printf("L\n");
                if(a[order[i]].fx==0) printf("Turning\n");
            }
        }

        printf("\n");
    }

    return 0;
}


UVA 10881 - Piotr's Ants(思维题)

上一篇:斐波那契查找


下一篇:iOS Dev (40) UIView 的几个重要方法