poj 2632 Crashing Robots

点击打开链接

Crashing Robots
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 6655   Accepted: 2886

Description

In a modernized warehouse, robots are used to fetch the goods. Careful planning is needed to ensure that the robots reach their destinations without crashing into each other. Of course, all warehouses are rectangular, and all robots occupy a circular floor
space with a diameter of 1 meter. Assume there are N robots, numbered from 1 through N. You will get to know the position and orientation of each robot, and all the instructions, which are carefully (and mindlessly) followed by the robots. Instructions are
processed in the order they come. No two robots move simultaneously; a robot always completes its move before the next one starts moving. 

A robot crashes with a wall if it attempts to move outside the area of the warehouse, and two robots crash with each other if they ever try to occupy the same spot.

Input

The first line of input is K, the number of test cases. Each test case starts with one line consisting of two integers, 1 <= A, B <= 100, giving the size of the warehouse in meters. A is the length in the EW-direction, and B in the NS-direction. 

The second line contains two integers, 1 <= N, M <= 100, denoting the numbers of robots and instructions respectively. 

Then follow N lines with two integers, 1 <= Xi <= A, 1 <= Yi <= B and one letter (N, S, E or W), giving the starting position and direction of each robot, in order from 1 through N. No two robots start at the same position. 

poj 2632 Crashing Robots 

Figure 1: The starting positions of the robots in the sample warehouse


Finally there are M lines, giving the instructions in sequential order. 

An instruction has the following format: 

< robot #> < action> < repeat> 

Where is one of
  • L: turn left 90 degrees,
  • R: turn right 90 degrees, or
  • F: move forward one meter,

and 1 <= < repeat> <= 100 is the number of times the robot should perform this single move.

Output

Output one line for each test case:
  • Robot i crashes into the wall, if robot i crashes into a wall. (A robot crashes into a wall if Xi = 0, Xi = A + 1, Yi = 0 or Yi = B + 1.)
  • Robot i crashes into robot j, if robots i and j crash, and i is the moving robot.
  • OK, if no crashing occurs.

Only the first crash is to be reported.

Sample Input

4
5 4
2 2
1 1 E
5 4 W
1 F 7
2 F 7
5 4
2 4
1 1 E
5 4 W
1 F 3
2 F 1
1 L 1
1 F 3
5 4
2 2
1 1 E
5 4 W
1 L 96
1 F 2
5 4
2 3
1 1 E
5 4 W
1 F 4
1 L 1
1 F 20

Sample Output

Robot 1 crashes into the wall
Robot 1 crashes into robot 2
OK
Robot 1 crashes into robot 2

根据指令计算机器人走的方向和距离就好了,模拟题,只是注意旋转方向时候如果用0 1 2 3 代表4个方向,那么需要注意旋转方向不同会引起求出来的方向值是个负值,比如当前方向是1,假设正向是left,那么负向就是right,那么当right转动100次的时候,得到的方向就是-99,取余结果是-3,就会wa,避免的方法就是如果向反方向旋转的时候,机器人的方向值先加上一个很大的4的倍数的值,这样再减去指令要求的次数,就能保证是一个正数了

#include<stdio.h>
#include<string.h>
struct robot
{
int x, y;
int dir;
};
int dire[4][2] = { {0, 1}, {1, 0}, {0, -1}, {-1, 0}};
robot rob[110];
int map[110][110];
int getdir(char ch)
{
switch(ch)
{
case 'N':
return 0;
case 'E':
return 1;
case 'S':
return 2;
case 'W':
return 3;
}
}
int main()
{
int k;
scanf("%d", &k);
while(k--)
{
int A, B, n, m;
scanf("%d%d%d%d", &A, &B, &n, &m);
memset(rob, 0, sizeof(rob));
memset(map, 0, sizeof(map));
int i;
for(i = 1; i <= n; i++)
{
int a, b;
char ch;
scanf("%d%d %c", &a, &b, &ch);
rob[i].x = a;
rob[i].y = b;
rob[i].dir = getdir(ch);
map[a][b] = i;
}
bool flag = 1;
for(i = 0; i < m; i++)
{
int num, rep;
char act;
scanf("%d %c%d", &num, &act, &rep);
if(flag)
{
switch(act)
{
case 'L':
rob[num].dir += 400;
rob[num].dir -= rep;
rob[num].dir %= 4;
break;
case 'R':
rob[num].dir += rep;
rob[num].dir %= 4;
break;
case 'F':
map[rob[num].x][rob[num].y] = 0;
while(rep--)
{
rob[num].x = rob[num].x + dire[rob[num].dir][0];
rob[num].y = rob[num].y + dire[rob[num].dir][1];
if(rob[num].x < 1 || rob[num].x > A || rob[num].y < 1 || rob[num].y > B)
{
printf("Robot %d crashes into the wall\n", num);
flag = 0;
break;
}
else if(map[rob[num].x][rob[num].y])
{
printf("Robot %d crashes into robot %d\n", num, map[rob[num].x][rob[num].y]);
flag = 0;
break;
}
}
if(rep == -1)
{
map[rob[num].x][rob[num].y] = num; }
break;
}
}
}
if(flag)
{
printf("OK\n");
}
}
return 0;
}
上一篇:lvs+keepalive实现双主模式(采用DR),同时实现TCP和UDP检测实现非web端的负载均衡,同时实现跨网段的通讯


下一篇:淘宝开源Web服务器Tengine基本安装步骤