1094 The Largest Generation (25 分)
A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.
Input Specification:
Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<N) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:
ID K ID[1] ID[2] ... ID[K]
where ID
is a two-digit number representing a family member, K
(>0) is the number of his/her children, followed by a sequence of two-digit ID
's of his/her children. For the sake of simplicity, let us fix the root ID
to be 01
. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.
Sample Input:
23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18
Sample Output:
9 4
【分析】求树的宽度及宽度最大所在的高度
总结:
dfs。这题目的样例也太少了吧。。
#include <iostream>
#include <cstdio>
#include <vector>
using namespace std;
const int maxn = 1e2 + 10;
int n, m;
int level[maxn], maxh = 0, ans = 0;
vector<int> v[maxn];
void dfs(int x, int h) {
level[h]++;
maxh = max(maxh, h);
for (int i = 0; i < v[x].size(); i++) {
dfs(v[x][i], h + 1);
}
}
void solve() {
fill(level, level + n, 0);
dfs(1, 1);
int index;
for (int i = 1; i <= maxh; i++) {
if (ans < level[i]) {
ans = level[i];
index = i;
}
}
cout << ans << " " << index;
}
int main() {
cin >> n >> m;
for (int i = 0; i < m; i++) {
int id, k;
cin >> id >> k;
for (int j = 0; j < k; j++) {
int t;
scanf("%d", &t);
v[id].push_back(t);
}
}
solve();
return 0;
}