Longest Ordered Subsequence

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence ( a1a2, ..., aN) be any sequence ( ai1ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8). 

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

最长连续递增子序列,注意要把所有项初始成1,不要忘了第0项

输入数据有多组,吃了看不懂英语的亏

#include<iostream>
#include<string>
#include<stack>
using namespace std;


int main() {
    int n;

    while (cin >> n) {
        int a[1001] = { 0 };
        int b[1001] = { 0 };
        for (int i = 0; i < n; i++) {
            cin >> a[i];
        }
        int max = 0;
        for (int i = 0; i < n; i++) {
            b[i] = 1;
            for (int j = 0; j < i; j++) {
                if (a[i] > a[j] && b[j] + 1 > b[i]) {
                    b[i] = b[j] + 1;
                }
            }
            if (max < b[i]) {
                max = b[i];
            }
        }
        cout << max << endl;
    }


    return 0;
}

 

上一篇:javascript-用浏览器内置JS数值求解三角函数方程


下一篇:攻防世界simple_php