2^x mod n = 1
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13341 Accepted Submission(s): 4143
Problem Description
Give a number n, find the minimum x(x>0) that satisfies 2^x mod n = 1.
Input
One positive integer on each line, the value of n.
Output
If the minimum x exists, print a line with 2^x mod n = 1.
Print 2^? mod n = 1 otherwise.
You should replace x and n with specific numbers.
Print 2^? mod n = 1 otherwise.
You should replace x and n with specific numbers.
Sample Input
2
5
Sample Output
2^? mod 2 = 1
2^4 mod 5 = 1
Author
MA, Xiao
做为一个ACMer,还是好好看看上面的百度百科吧。挺实用的
依据模P乘法逆元:对于整数a、p假设存在整数b,满足a*b mod p=1则称b是a的模P乘法逆元。
a存在模P的乘法逆元的充要条件是gcd(a,p)=1。令a=2^x。b=1。p=n
则若存在x使用2^x mod n=1则gcd(2^x,n)=1
(1)由于要求x的值大于0。
则2^x的因子中仅仅有一个2,所以当n为偶数时gcd(2^x,n)=2k(k=1,2,3...)。即此时不存在x使得2^x mod n=1。
(2)当n为奇数时gcd(2^x,n)=1。则必存在x使得2^x mod n=1。
(3)因为不论什么数模1的结果为0,所以当n=1时,不管x取何值,2^x mod n=0.
综合上述(1),(2),(3)。当n的值为1或偶数时,不存在x使得2^x mod n=1。其他情况则必存在一x使得2^x mod n =1。
代码:
#include <stdio.h> int main()
{
int n ;
while(~scanf("%d",&n))
{
if(n==1 || n%2==0)
{
printf("2^? mod %d = 1\n",n);
}
else
{
int j = 1, mi=2;
while(true)
{
mi %= n ;
if(mi == 1)
{
printf("2^%d mod %d = 1\n",j,n) ;
break ;
}
mi *= 2 ;
++j ;
}
}
}
return 0 ;
}
与君共勉