All in All UVA - 10340

 You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.

 Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.

Input

 The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace. Input is terminated by EOF.

Output

 For each test case output, if s is a subsequence of t.

Sample Input

sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

Sample Output

Yes
No
Yes
No

HINT

   这个题用C++做的,一开始数组开小了,后来开太大了,果断选择string。代码简单,看就好不多解释。

Accepted

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;

int main() {
	string s, t;
	while (cin >> s >> t)
	{
		int j = 0;
		for (int i = 0;i < t.length(); i++)
			if (s[j] == t[i])j++;
		cout << (j == s.length() ? "Yes" : "No" )<< endl;
   }
	return 0;
}
上一篇:CodeForces - 985F Isomorphic Strings


下一篇:字符串操作 — Google Guava