Integer Inquiry

  这个题主要解决的是精度问题,若不同前面用0补上,字符串前加"0".

 

Integer Inquiry

 

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)

 

Total Submission(s) : 7   Accepted Submission(s) : 2

 

Font: Times New Roman | Verdana | Georgia

 

Font Size: ← →

 

Problem Description

 

One of the first users of BIT‘s new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.
``This supercomputer is great,‘‘ remarked Chip. ``I only wish Timothy were here to see these results.‘‘ (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)

 

Input

 

The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).

The final input line will contain a single zero on a line by itself.

 

Output

 

Your program should output the sum of the VeryLongIntegers given in the input.


This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

 

Sample Input

 

1

 

 

 

 

 

123456789012345678901234567890

 

123456789012345678901234567890

 

123456789012345678901234567890

 

0

 

Sample Output

 

370370367037037036703703703670

 

这个题主要解决的是:首先是把输入的数的位数相同,若不同前面补0

 

#include<stdio.h>

 

#include<string>

 

#include<iostream>

 

using namespace std;

 

 

 

//高精度加法

 

//只能是两个正数相加

 

string add(string str1,string str2)//高精度加法

 

{

 

    string str;

 

 

 

    int len1=str1.length();

 

    int len2=str2.length();

 

    //前面补0,弄成长度相同

 

    if(len1<len2)

 

    {

 

        for(int i=1;i<=len2-len1;i++)

 

           str1="0"+str1;

 

    }

 

    else

 

    {

 

        for(int i=1;i<=len1-len2;i++)

 

           str2="0"+str2;

 

    }

 

    len1=str1.length();

 

    int cf=0;

 

    int temp;

 

    for(int i=len1-1;i>=0;i--)

 

    {

 

        temp=str1[i]-‘0‘+str2[i]-‘0‘+cf;

 

        cf=temp/10;

 

        temp%=10;

 

        str=char(temp+‘0‘)+str;

 

    }

 

    if(cf!=0)  str=char(cf+‘0‘)+str;

 

    return str;

 

}

 

 

 

 

 

int main()

 

{

 

    int T;

 

    scanf("%d",&T);

 

    while(T--)

 

    {

 

        string sum="0";

 

        string str1;

 

        while(cin>>str1)

 

        {

 

            if(str1=="0")break;

 

            sum=add(sum,str1);

 

        }

 

        cout<<sum<<endl;

 

        if(T>0)cout<<endl;

 

    }

 

return 0;

 

}

Integer Inquiry

上一篇:launch4j


下一篇:OpenWrt -忘记密码