Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).
Input
Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.
Output
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.
Sample Input
-1000000 9
Sample Output
-999,991
解题思路:
给出两个整数a,b,求和并按照指定格式输出,简单的模拟一下就行。
#include<cstdio>
void myprint(int num){
if(num<0){
printf("-");
num=-num;
}
if(num>999999){
printf("%d,%d%d%d,%d%d%d",num/1000000,num/100000%10,num/10000%10,num/1000%10,num/100%10,num/10%10,num%10);
}
else if(num>999){
printf("%d,%d%d%d",num/1000,num/100%10,num/10%10,num%10);
}
else{
printf("%d",num);
}
}
int main(){
int a,b;
scanf("%d%d",&a,&b);
int sum=a+b;
myprint(sum);
return 0;
}