Prime Ring Problem(回溯)

Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

Prime Ring Problem(回溯)
 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
6 8
 
思路:经典题目。

Sample Output
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2


#include <stdio.h>
#include <math.h>

bool isprime[38],vis[20];
int n,A[20];

void trackback(int cur)
{
    int i;

    if(cur==n+1 && isprime[A[1]+A[n]])
    {
        for(i=1;i<=n;i++)
        {
            printf("%d",A[i]);
            if(i<n) printf(" ");
            else printf("\n");
        }
    }
    else if(cur<=n)
    {
        for(i=2;i<=n;i++)
        {
            if(isprime[A[cur-1]+i] && !vis[i])
            {
                A[cur]=i;
                vis[i]=1;
                trackback(cur+1);
                vis[i]=0;
            }
        }
    }
}

int main()
{
    int i,j,count=1;

    for(i=2;i<=37;i++)//初始化素数表
    {
        isprime[i]=1;
        for(j=2;j<=sqrt(i);j++)
        {
            if(i%j==0)
            {
                isprime[i]=0;
                break;
            }
        }
    }

    for(i=1;i<=19;i++) vis[i]=0;//标志数组清零

    A[1]=1;
    while(~scanf("%d",&n))
    {
        printf("Case %d:\n",count++);
        trackback(2);
        printf("\n");
    }
}


Prime Ring Problem(回溯)

上一篇:EntityFramework之领域驱动设计实践【反模式】


下一篇:给定一个长度为N的数组,找出一个最长的单调自增子序列(不一定连续,但是顺序不能乱). 第二解