PAT甲级 1002 A+B for Polynomials
This time, you are supposed to find A+B where A and B are two polynomials.
Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K N1 aN1 N2 aN2 ... NK aNK
where K is the number of nonzero terms in the polynomial, Ni and aNi
(i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤NK<⋯<N2<N1≤1000.
Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output:
3 2 1.5 1 2.9 0 3.2
多项式的A+B,符合PAT的套路,坑多,注意相加也会出现0的情况,直接暴力算即可,AC代码如下:
#include<bits/stdc++.h>
using namespace std;
const int maxn = 1e3+5;
double p[maxn]={0.0};
int k, n, ans = 0;
double a;
int main() {
scanf("%d", &k);
for(int i = 0; i < k; i++) {
scanf("%d %lf", &n, &a);
p[n] += a;
}
scanf("%d", &k);
for(int i = 0; i < k; i++) {
scanf("%d %lf", &n, &a);
p[n] += a;
}
for(int i = 0; i < maxn; i++) {
if(p[i] != 0) {
ans++;
}
}
printf("%d", ans);
for(int i = maxn; i >= 0; i--) {
if(p[i] != 0) {
printf(" %d %.1f", i, p[i]);
}
}
return 0;
}
旺 崽
发布了248 篇原创文章 · 获赞 13 · 访问量 2万+
私信
关注