1002 A+B for Polynomials (25 分)

1002 A+B for Polynomials (25 分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms(非零项) in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents(指数) and coefficients(系数), respectively. It is given that 1≤K≤10,0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

 


题目要求计算两个多项式之和, 格式为:

多项式项数, 指数 系数 指数 系数 

输出结果和输入格式相同,保留一位小数


#include<iostream>
using namespace std;
int main()
{
	float c[1001] = { 0 };
	int m, n, t;
	float num;
	cin >> m; //第一个多项式非零项数量
	for (int i = 0; i < m; i++)
	{
		cin>>t>>num;
		c[t] += num;
	}
	cin>>n; //第二个多项式非零项数量
	for (int i = 0; i < n; i++)
	{
		cin>>t>>num;
		c[t] += num;
	}
	int cnt = 0;
	for (int i = 0; i < 1001; i++)
	{
		if (c[i] != 0)cnt++;
	}
	cout<<cnt; //非零项数量
	for (int i = 1000; i >= 0; i--)
	{
		if (c[i] != 0.0)
			printf(" %d %.1f", i, c[i]);
	}
	return 0;
}

 

上一篇:1002 写出这个数 (20 分)


下一篇:1002 写出这个数