描述
You are the owner of SmallCableCo and have purchased the franchise rights for a small town. Unfortunately, you lack enough funds to start your business properly and are relying on parts you have found in an old warehouse you bought. Among your finds is a single spool of cable and a lot of connectors. You want to figure out whether you have enough cable to connect every house in town. You have a map of town with the distances for all the paths you may use to run your cable between the houses. You want to calculate the shortest length of cable you must have to connect all of the houses together.
输入
Only one town will be given in an input.
- The first line gives the length of cable on the spool as a real number.
- The second line contains the number of houses, N
- The next N lines give the name of each house‘s owner. Each name consists of up to 20 characters {a~z, A~Z,0~9} and contains no whitespace or punctuation.
- Next line: M, number of paths between houses
- next M lines in the form
< house name A > < house name B > < distance >
Where
the two house names match two different names in the list above and the
distance is a positive real number. There will not be two paths between the
same pair of houses.
输出
The output
will consist of a single line. If there is not enough cable to connect all of
the houses in the town, output
Not enough cable
If there is enough
cable, then output
Need < X > miles of cable
Print X to the
nearest tenth of a mile (0.1).
样例输入
100.0
4
Jones
Smiths
Howards
Wangs
5
Jones Smiths 2.0
Jones Howards 4.2
Jones Wangs 6.7
Howards Wangs 4.0
Smiths Wangs 10.0
样例输出
Need 10.2 miles of cable
题目来源
#include <stdio.h> #include <string.h> #define MAXN 350 #define inf 0x3f3f3f3f int
N,M;
char
p[MAXN][25];
double
map[MAXN][MAXN];
int
visited[MAXN];
double
dist[MAXN];
int
find( char
ch[25]){
for ( int
i=1; i<=N; i++){
if ( strcmp (p[i],ch)==0) return
i;
}
return
0;
} double
prim( int
begin){
double
r=0;
for ( int
i=1; i<=N; i++){
visited[i]= false ;
dist[i]=map[begin][i];
}
visited[begin]= true ;
for ( int
j=1; j<N; j++){
int
k=-1;
double
min=inf;
for ( int
i=1; i<=N; i++){
if (!visited[i]&&dist[i]<min){
min=dist[i];
k=i;
}
}
if (min!=inf){
r+=min;
}
visited[k]= true ;
for ( int
i=1; i<=N; i++){
if (!visited[i]&&map[k][i]<dist[i]){
dist[i]=map[k][i];
}
}
}
return
r;
} int
main( int
argc, char
*argv[])
{ double
len,w;
char
a[25],b[25];
while ( scanf ( "%lf" ,&len)!=EOF){
scanf ( "%d" ,&N);
for ( int
i=1; i<=N; i++){
scanf ( "%s" ,p[i]);
}
for ( int
i=1; i<=N; i++){
for ( int
j=1; j<=N; j++){
if (i==j)map[i][j]=0;
else
map[i][j]=inf;
}
}
scanf ( "%d" ,&M);
while (M--){
scanf ( "%s %s %lf" ,a,b,&w);
int
u=find(a);
int
v=find(b);
map[u][v]=w;
map[v][u]=w;
}
double
ans=prim(1);
if (ans<=len){
printf ( "Need %.1lf miles of cable\n" ,ans);
} else {
printf ( "Not enough cable\n" );
}
}
return
0;
} |