NYOJ 69 数的长度(数学)

数的长度

时间限制:3000 ms  |  内存限制:65535 KB
难度:1
 
描述

N!阶乘是一个非常大的数,大家都知道计算公式是N!=N*(N-1)······*2*1.现在你的任务是计算出N!的位数有多少(十进制)?

 
输入
首行输入n,表示有多少组测试数据(n<10)
随后n行每行输入一组测试数据 N( 0 < N < 1000000 )
输出
对于每个数N,输出N!的(十进制)位数。
样例输入
3
1
3
32000
样例输出
1
1
130271

斯特林公式(点击打开链接(*)):

n!~√(2*PI*n)*(n/e)^n

 #include<stdio.h>
#include<cmath>
#define PI 3.141592653589793239
#define e 2.718281828459045
int main()
{
int i,j,k,n,N;
double sum;
scanf("%d",&n);
while(n--)
{
sum=;
scanf("%d",&N);
sum=log10(sqrt(*PI*N))+N*log10(N/e);
k=(int)sum+;
printf("%d\n",k);
}
return ;
}
上一篇:python连接outlook邮箱


下一篇:Formelsammlung Mathematik: Bestimmte Integrale: Form R(x)