hdu1080 Human Gene Functions() 2016-05-24 14:43 65人阅读 评论(0) 收藏

Human Gene Functions

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 3103    Accepted Submission(s): 1761

Problem Description
It is well known that a human gene can be considered as a sequence, consisting of four nucleotides, which are simply denoted by four letters, A, C, G, and T. Biologists have been interested in identifying human genes and determining their functions, because
these can be used to diagnose human diseases and to design new drugs for them. 



A human gene can be identified through a series of time-consuming biological experiments, often with the help of computer programs. Once a sequence of a gene is obtained, the next job is to determine its function. One of the methods for biologists to use in
determining the function of a new gene sequence that they have just identified is to search a database with the new gene as a query. The database to be searched stores many gene sequences and their functions – many researchers have been submitting their genes
and functions to the database and the database is freely accessible through the Internet. 



A database search will return a list of gene sequences from the database that are similar to the query gene. Biologists assume that sequence similarity often implies functional similarity. So, the function of the new gene might be one of the functions that
the genes from the list have. To exactly determine which one is the right one another series of biological experiments will be needed. 



Your job is to make a program that compares two genes and determines their similarity as explained below. Your program may be used as a part of the database search if you can provide an efficient one. 



Given two genes AGTGATG and GTTAG, how similar are they? One of the methods to measure the similarity of two genes is called alignment. In an alignment, spaces are inserted, if necessary, in appropriate positions of the genes to make them equally long and score
the resulting genes according to a scoring matrix. 



For example, one space is inserted into AGTGATG to result in AGTGAT-G, and three spaces are inserted into GTTAG to result in –GT--TAG. A space is denoted by a minus sign (-). The two genes are now of equal length. These two strings are aligned: 



AGTGAT-G 

-GT--TAG 



In this alignment, there are four matches, namely, G in the second position, T in the third, T in the sixth, and G in the eighth. Each pair of aligned characters is assigned a score according to the following scoring matrix.

hdu1080 Human Gene Functions()                                                                                            2016-05-24 14:43             65人阅读              评论(0)              收藏


* denotes that a space-space match is not allowed. The score of the alignment above is (-3)+5+5+(-2)+(-3)+5+(-3)+5=9. 



Of course, many other alignments are possible. One is shown below (a different number of spaces are inserted into different positions): 



AGTGATG 

-GTTA-G 



This alignment gives a score of (-3)+5+5+(-2)+5+(-1) +5=14. So, this one is better than the previous one. As a matter of fact, this one is optimal since no other alignment can have a higher score. So, it is said that the similarity of the two genes is 14.
 
Input
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case consists of two lines: each line contains an integer, the length of a gene, followed by a gene sequence. The length of each gene sequence
is at least one and does not exceed 100. 
 
Output
The output should print the similarity of each test case, one per line. 
 
Sample Input
2
7 AGTGATG
5 GTTAG
7 AGCTATT
9 AGCTTTAAA
 
Sample Output
14
21
 
_____________________________________________________________________

本题为最长公共子序列(LCS)的变形,处理方法相似。

再第i,j位判断前一位的各种情况取最大。

状态转移方程为
dp[i][j]=max(dp[i-1][j-1]+link[change(s1[i])][change(s2[j])],max(dp[i-1][j]+link[change(s1[i])][4],dp[i][j-1]+link[4[change(s2[j])]));

其中change是将字符转化为link数组下标,link数组记录各种匹配的值

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
int link[10][10]={{5,-1,-2,-1,-3},{-1,5,-3,-2,-4},{-2,-3,5,-2,-2},{-1,-2,-2,5,-1},{-3,-4,-2,-1,0}};
int dp[105][105];
int change(char a)
{
if(a=='A')
return 0;
if(a=='C')
return 1;
if(a=='G')
return 2;
if(a=='T')
return 3;
if(a=='-')
return 4;
}
int main()
{
int o,len1,len2;
char s1[105],s2[105];
while(~scanf("%d",&o))
{
while(o--)
{
scanf(" %d %s",&len1,s1+1);
scanf(" %d %s",&len2,s2+1);
dp[0][0]=0;
for(int i=1;i<=len1;i++)
{
dp[i][0]=dp[i-1][0]+link[change(s1[i])][4];
}
for(int i=1;i<=len2;i++)
{
dp[0][i]=dp[0][i-1]+link[change(s2[i])][4];
} for(int i=1;i<=len1;i++)
for(int j=1;j<=len2;j++)
{
dp[i][j]=max(dp[i-1][j-1]+link[change(s1[i])][change(s2[j])],max(dp[i-1][j]+link[change(s1[i])][4],dp[i][j-1]+link[4][change(s2[j])])); } printf("%d\n",dp[len1][len2]); }
}
return 0;
}
上一篇:js checkbox


下一篇:tp5 mysql 查询表中每个类的前n条数据