hdoj:2070

Fibbonacci Number

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 22530    Accepted Submission(s): 10375

Problem Description
Your objective for this question is to develop a program which will generate a fibbonacci number. The fibbonacci function is defined as such:

f(0) = 0
f(1) = 1
f(n) = f(n-1) + f(n-2)

Your program should be able to handle values of n in the range 0 to 50.
 

Input
Each test case consists of one integer n in a single line where 0≤n≤50. The input is terminated by -1.
 

Output
Print out the answer in a single line for each test case.
 

Sample Input
3
4
5
-1
 

Sample Output
2
3
5
Hint
Note:

you can use 64bit integer: __int64

费波纳列数

#include <iostream>
using namespace std; const int limit = 51;
_int64 fib[limit]; int main()
{
int num;
fib[0] = 0;
fib[1] = 1;
for (int i = 2; i <= limit; i++)
{
fib[i] = fib[i - 1] + fib[i - 2];
} while (cin >> num && num!=-1)
{
cout << fib[num] << endl;
}
return 0;
}
上一篇:网站SEO,HTTP请求的关键数字----6


下一篇:RH033读书笔记(3)-Lab 4 Browsing the Filesystem