输入一个整数序列a1,a2,a3...,an。当ai不等于-1时将ai进栈;当ai=-1时,输出栈顶元素并将其出栈。
输入
多组数据,每组数据有两行,第一行为序列的长度n,第二行为n个整数,整数之间用空格分隔。当n=0时输入结束。
输出
对于每一组数据输出若干行。每行为相应的出栈元素。当出栈异常时,输出“POP ERROR”并结束本组数据的输出。
输入样例 1
5
1 2 -1 -1 1
5
1 -1 -1 2 2
0
输出样例 1
2 1 1 POP ERROR
思路:
写一个Empty函数来判断当前是不是还有元素在栈里,如果没有元素但还是输入-1的话,说明输入不对了,要中止输出。
这是错误代码,用的是即时输入即时判断的方式,就是说每次都把输入的数据存到temp里,并不保留,这样就会出现错误。因为按题目的意思,“中止输入”后,同一序列的元素还是会被输入到程序中,而不会重新输入下一个链表的元素个数。
#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
typedef struct Stack
{
struct Stack* next;
int data;
}stk,*linkstack;
void Init(linkstack& s)
{
s = NULL;
}
void Push(linkstack& s,int x)
{
linkstack t = new stk;
t->data = x;
t->next = s;
s = t;
}
void Pop(linkstack& s)
{
cout << s->data << endl;
linkstack t = s;
s=t->next;
delete t;
}
bool Empty(linkstack s)
{
return s == NULL;
}
int main()
{
int n;
cin >> n;
while (n != 0)
{
linkstack s;
Init(s);
for (int i = 0; i < n; i++)
{
int temp;
cin >> temp;
if (temp == -1&&!Empty(s))
Pop(s);
else if (temp == -1 && Empty(s))
{
cout << "POP ERROR" << endl;
break;
}
else
Push(s,temp);
}
cin >> n;
}
return 0;
}
更改方式:先把所有的数据存起来,然后再判断每个数据是否符合要求~
这是正确的代码:
#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
typedef struct Stack
{
struct Stack* next;
int data;
}stk,*linkstack;
void Init(linkstack& s)
{
s = NULL;
}
void Push(linkstack& s,int x)
{
linkstack t = new stk;
t->data = x;
t->next = s;
s = t;
}
void Pop(linkstack& s)
{
cout << s->data << endl;
linkstack t = s;
s=t->next;
delete t;
}
bool Empty(linkstack s)
{
return s == NULL;
}
int main()
{
int n;
cin >> n;
while (n != 0)
{
linkstack s;
Init(s);
int a[100];//先用数组存起来~
for (int i = 0; i < n; i++)
cin >> a[i];
for(int i=0;i<n;i++)
{
if (a[i] == -1&&!Empty(s))
Pop(s);
else if (a[i] == -1 && Empty(s))
{
cout << "POP ERROR" << endl;
break;
}
else
Push(s,a[i]);
}
cin >> n;
}
return 0;
}