Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 7921 | Accepted: 3829 |
Description
But there is a big problem with piggy-banks. It is not possible to
determine how much money is inside. So we might break the pig into
pieces only to find out that there is not enough money. Clearly, we want
to avoid this unpleasant situation. The only possibility is to weigh
the piggy-bank and try to guess how many coins are inside. Assume that
we are able to determine the weight of the pig exactly and that we know
the weights of all coins of a given currency. Then there is some minimum
amount of money in the piggy-bank that we can guarantee. Your task is
to find out this worst case and determine the minimum amount of cash
inside the piggy-bank. We need your help. No more prematurely broken
pigs!
Input
input consists of T test cases. The number of them (T) is given on the
first line of the input file. Each test case begins with a line
containing two integers E and F. They indicate the weight of an empty
pig and of the pig filled with coins. Both weights are given in grams.
No pig will weigh more than 10 kg, that means 1 <= E <= F <=
10000. On the second line of each test case, there is an integer number N
(1 <= N <= 500) that gives the number of various coins used in
the given currency. Following this are exactly N lines, each specifying
one coin type. These lines contain two integers each, Pand W (1 <= P
<= 50000, 1 <= W <=10000). P is the value of the coin in
monetary units, W is it's weight in grams.
Output
exactly one line of output for each test case. The line must contain
the sentence "The minimum amount of money in the piggy-bank is X." where
X is the minimum amount of money that can be achieved using coins with
the given total weight. If the weight cannot be reached exactly, print a
line "This is impossible.".
Sample Input
3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4
Sample Output
The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible. 完全背包的问题,但要把背包装满!!!
#include <stdio.h>
#include <string.h> int ff[10002];
int p[10002];
int w[10002]; int min(int a, int b)
{
if(a>b)
return b;
else
return a;
} int main()
{
int t;
scanf("%d", &t ); int e, f, dd ;
int i, j, k, n;
while(t--)
{
memset(w,0, sizeof(w));
memset(p, 0, sizeof(p)); scanf("%d %d", &e, &f );
dd = f - e;
scanf("%d", &n ); for(i=1; i<=n; i++)
{
scanf("%d %d", &p[i], &w[i] );
} ff[0]=0; for(j=1; j<10002; j++)
{
ff[j] = 99999999;
}
for(i=1; i<=n; i++)
{
for(k=w[i]; k<=dd; k++)
{
ff[k] = min(ff[k], ff[k-w[i]]+p[i] );
}
}
if(ff[dd]==99999999 )
{
printf("This is impossible.\n");
}
else
{
printf("The minimum amount of money in the piggy-bank is %d.\n", ff[dd] );
}
} return 0;
}