The Blocks Problem UVA - 101

  Many areas of Computer Science use simple, abstract domains for both analytical and empirical studies. For example, an early AI study of planning and robotics (STRIPS) used a block world in which a robot arm performed tasks involving the manipulation of blocks.

  In this problem you will model a simple block world under certain rules and constraints. Rather than determine how to achieve a specified state, you will “program” a robotic arm to respond to a limited set of commands.

  The problem is to parse a series of commands that instruct a robot arm in how to manipulate blocks that lie on a flat table. Initially there are n blocks on the table (numbered from 0 to n−1) with block bi adjacent to block bi+1 for all 0≤ i < n−1 as shown in the diagram below:

The Blocks Problem UVA - 101

Initial Blocks World

  The valid commands for the robot arm that manipulates blocks are:

  • move a onto b

  where a and b are block numbers, puts block a onto block b after returning any blocks that are stacked on top of blocks a and b to their initial positions.

  • move a over b

  where a and b are block numbers, puts block a onto the top of the stack containing block b, after returning any blocks that are stacked on top of block a to their initial positions.

  • pile a onto b

  where a and b are block numbers, moves the pile of blocks consisting of block a, and any blocks that are stacked above block a, onto block b. All blocks on top of block b are moved to their initial positions prior to the pile taking place. The blocks stacked above block a retain their order when moved.

  • pile a over b

  where a and b are block numbers, puts the pile of blocks consisting of block a, and any blocks that are stacked above block a, onto the top of the stack containing block b. The blocks stacked above block a retain their original order when moved.

  • quit

  terminates manipulations in the block world.

  Any command in which a = b or in which a and b are in the same stack of blocks is an illegal command. All illegal commands should be ignored and should have no affect on the configuration of blocks.

Input

  The input begins with an integer n on a line by itself representing the number of blocks in the block world. You may assume that 0 < n < 25.

  The number of blocks is followed by a sequence of block commands, one command per line. Your program should process all commands until the quit command is encountered.

  You may assume that all commands will be of the form specified above. There will be no syntactically incorrect commands.

Output

  The output should consist of the final state of the blocks world. Each original block position numbered i (0≤ i < n where n is the number of blocks) should appear followed immediately by a colon. If there is at least a block on it, the colon must be followed by one space, followed by a list of blocks that appear stacked in that position with each block number separated from other block numbers by a space. Don’t put any trailing spaces on a line.

  There should be one line of output for each block position (i.e., n lines of output where n is the integer on the first line of input).

Sample Input

10
move 9 onto 1
move 8 over 1
move 7 over 1
move 6 over 1
pile 8 over 6
pile 8 over 5
move 2 over 1
move 4 over 9
quit

Sample Output

0: 0
1: 1 9 2 4
2:
3: 3
4:
5: 5 8 7 6
6:
7:
8:
9:

HINT

  这个要化繁为简,找到各个指令的共同点。对比分析可以直到,只有“onto”和“move”指令才需要清楚上方的木块,因此只需要判断这两个即可。其他的情况可以全部当作从一个堆上转移到另一个堆上面。这样主要的函数就完成了。剩下的就是输出函数很简单不解释。另外题目中涉及大量数组末尾元素的添加和删除,因此使用vector合适。由题意我们需要知道每一个方块的位置,因此增加了坐标数组来时刻记录方块的坐标。

Accepted

#include<algorithm>
#include <iostream>
#include<vector>
#include<string>
using namespace std;

vector<int>block[30];
int id[30][2];		//坐标数组

void print(int n)	//输出结果
{
	for (int i = 0;i < n;i++)
	{
		cout << i << ":";
		for (int j = 0;j < block[i].size();j++)
			cout << " " << block[i][j];
		cout << endl;
	}
}

void a2b(int a, int b)			//从一个堆移动到另一个堆
{
	int m = id[a][0];	//a的坐标(m,n)
	int n = id[a][1];
	int p = id[b][0];	//b的横坐标
	for (int i = n;i < block[m].size();i++)
	{
		int t = block[m][i];						
		id[t][0] = p;id[t][1] = block[p].size();	//更新坐标
		block[p].push_back(t);						//将每一个元素一次添加到另一个堆的顶部
	}
	while (n != block[m].size())block[m].pop_back();//添加完成后删除原来堆上的木块,相当于”移动“
}

void blockclear(int a)				//归为函数
{
	int m = id[a][0];	//a的坐标(m,n)
	int n = id[a][1];
	for (int i = block[m].size()-1;i > n;i--)
	{
		int t = block[m][i];
		block[t].clear();
		block[t].push_back(t);		//归为到原本的位置
		id[t][0]= t;id[t][1] = 0;	//更新坐标
		block[m].pop_back();		//弹出
	}
}

int main()
{
	int n,a,b;
	cin >> n;
	for (int i = 0;i < n;i++)
	{
		block[i].push_back(i);
		id[i][0] = i;id[i][1] = 0;
	}
	string s1, s2;
	while (cin>>s1&&s1!="quit")		//判断终止
	{
		int ida, idb;
		cin >> a >> s2 >> b;
		if (id[a][0] == id[b][0])continue;		//判断是否合法
		else
		{
			if (s2 == "onto")blockclear(b);		//当s2和s1分别为onto和move时此需要清楚木块上方
			if (s1 == "move")blockclear(a);
			a2b(a, b);
		}
	}
	 print(n);		//打印
}
上一篇:RISCV GCC 链接文件 常用命令


下一篇:Less mobile, more everything-重新思考Mobile