Problem Description
N 的阶乘(记作 N!)是指从 1 到 N(包括 1 和 N)的所有整数的乘积。
阶乘运算的结果往往都非常的大。
现在,给定数字 N,请你求出 N! 的最右边的非零数字是多少。
例如 5 != 1 × 2 × 3 × 4 × 5 = 120,所以 5! 的最右边的非零数字是 2。
Input Format
共一行,包含一个整数 N。
Output Format
输出一个整数,表示 N! 的最右边的非零数字。
Scope of Data
1 ≤ N ≤ 1000
Sample Input
Sample Output
Idea
1 <= N <= 1000,暴力求出阶乘可能会溢出,题目要求我们求得最右边的非零数字,则我们需要将最右边为0的数值去掉,又由于0一般都是2和5相乘得到,因此我们需要将每个枚举的数值中的2和5除去并计数,再将剩余的数值乘回ans里面(这里需要每次将ans对10取模,防止溢出),对于可能不会构成0的2或5最后乘回ans并对10取模,得到最后结果。
Program Code
#include <iostream>
#include <algorithm>
using namespace std;
int N;
int main()
{
int ans = 1, cnt2 = 0, cnt5 = 0;
cin >> N;
for(int i = 1; i <= N; ++ i) //枚举
{
int t = i;
while(t % 2 == 0) //统计每个t中2的个数
{
cnt2 ++;
t /= 2;
}
while(t % 5 == 0) //统计每个t中5的个数
{
cnt5 ++;
t /= 5;
}
ans = ans * t % 10; //为防止溢出,每次乘数都mod10
}
//将剩余的2或5乘回ans中
int k = min(cnt2, cnt5);
for(int i = 0; i < cnt2 - k; ++ i)
ans = ans * 2 %10;
for(int i = 0; i < cnt5 - k; ++ i)
ans = ans * 5 % 10;
cout << ans;
return 0;
}
- If you have any questions,please feel free to communicate with me.