Problem A: 小蛮腰

Description

输出一个用符号组成的“小蛮腰”,如样例所示。

Input

输入一个奇数n>0,以及一个符号,中间用一个空格隔开。

Output

输出n行的一个“小蛮腰”。

Sample Input

7 *

Sample Output

******* ***** *** * *** ***** *******

HINT

输入时,格式控制串需要使用"%d %c“,以便跳过中间的空格。

Append Code

#include<stdio.h>
#include<stdlib.h>
#include<math.h>

int main()
{
    int a;
    char m;
    scanf("%d %c",&a,&m);
    if(a%2==1){
        for(int i=0;i<=a/2;i++)
        {
            for(int u=0;u<i;u++){
                    printf(" ");
                }
            for(int j=a-2*i;j>0;j--){

                if(j<2) printf("%c\n",m);
                else printf("%c",m);
            }

        }
        for(int i=a/2;i>0;i--)
        {
            for(int u=1;u<i;u++){
                    printf(" ");
                }
            for(int j=a-2*(i-1);j>0;j--){

                if(j<2) printf("%c\n",m);
                else printf("%c",m);
            }

        }
    }
    return 0;
}

上一篇:Codeforces Problem-1030A In Search of an Easy Problem


下一篇:[学习笔记]day3-一些双指针的题