7-7 最短工期

最短工期

一个项目由若干个任务组成,任务之间有先后依赖顺序。项目经理需要设置一系列里程碑,在每个里程碑节点处检查任务的完成情况,并启动后续的任务。现给定一个项目中各个任务之间的关系,请你计算出这个项目的最早完工时间。

输入格式:
首先第一行给出两个正整数:项目里程碑的数量 N(≤100)和任务总数 M。这里的里程碑从 0 到 N−1 编号。随后 M 行,每行给出一项任务的描述,格式为“任务起始里程碑 任务结束里程碑 工作时长”,三个数字均为非负整数,以空格分隔。

输出格式:
如果整个项目的安排是合理可行的,在一行中输出最早完工时间;否则输出"Impossible"。

输入样例 1:

9 12
0 1 6
0 2 4
0 3 5
1 4 1
2 4 1
3 5 2
5 4 0
4 6 9
4 7 7
5 7 4
6 8 2
7 8 4

输出样例 1:

18

输入样例 2:

4 5
0 1 1
0 2 2
2 1 3
1 3 4
3 2 5

输出样例 2:

Impossible

拓扑 加最小生成树

#include <iostream>
#include <cstring>
#include <algorithm>

using namespace std;
const int N = 100010;
int e[N],ne[N],h[N],w[N];
int d[N],q[N],dist[N];
int n,m,idx,res;

void add(int a, int b, int c)  // 添加一条边a->b,边权为c
{
    e[idx] = b, w[idx] = c, ne[idx] = h[a], h[a] = idx ++ ;
}


bool topsort()
{
    //  memset(dist , 0x3f, sizeof dist);
    int tt=-1,hh=0;
    for(int i=0;i<n;i++)
       if(d[i]==0)
          q[++tt]=i,dist[i]=0;
   
   while(tt>=hh)
   {
       int t=q[hh++];
       for(int i=h[t];i!=-1;i=ne[i])
       {
           int j=e[i];
           if(dist[j]<dist[t]+w[i])dist[j]=dist[t]+w[i];
        //   dist[j]=min(dist[j],dist[t]+w[i]);
           if(--d[j]==0)
           {
               q[++tt]=j;
           }
       }
   }

for(int i=0;i<n;i++)res=max(res,dist[i]);
   return tt==n-1;     //判断是否都进去了
}

int main()
{
    cin>>n>>m;
    memset(h, -1, sizeof h);
    for(int i=0;i<m;i++)
    {
       int a,b,c;
       cin>>a>>b>>c;
       add(a,b,c);
       d[b]++;;
    }
    if(topsort()) 
    {
        cout<<res<<endl;
    }
    else
    {
        puts("Impossible");
    }
    return 0;
}
上一篇:To_Heart—题解——[CQOI2017]老C的方块


下一篇:NPM安装Bootstrap VS. Bower安装Bootstrap