Description
Your task is to Calculate a
+ b
.
Input
There are multiple test cases. Each test case contains only one line. Each line consists of a pair of integers a
and b
( 1 <= a
, b
<=10e16 ) , separated by a space. Input is followed by a single line with a
= 0, b
= 0, which should not be processed.
Output
For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.
Sample Input
1 5
10 20
10000000000000000 10000000000000000
0 0
Sample Output
6
30
20000000000000000
题目解析
这道题其实和前两个题目没有什么本质上的区别,只是题目要求遇到a和b都等于0的时候退出循环,所以我们不在对比EOF,而是在循环中直接加一个判断条件决定是否结束读入,然后注意题目的数据范围超过了int类型,需要用long long int来存储,除此以外没有其他的更多坑点了。
代码实现
#include<bits/stdc++.h>
using namespace std;
int main()
{
long long int a,b;
while(cin>>a>>b)
{
if(a==0&&b==0)break;
a=a+b;
printf("%lld\n",a);
}
return 0;
}